Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60021 - [gtest] reports the wrong version

Attached to Project: Community Packages
Opened by William Wold (wmww) - Tuesday, 11 September 2018, 18:19 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 25 September 2018, 22:03 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
`/usr/bin/gtest-config --version` is supposed to produce the current gtest version, however for gtest 1.8.1 (the latest version) it still prints "1.8.0".

Importance:
gtest v1.8.1 broke Mir (https://aur.archlinux.org/packages/mir-git/). I've fixed the issues, but I need to know the correct gtest version in the build process.

Steps to reproduce:
$ pacman -S gtest
$ pacman -Q gtest
gtest 1.8.1-1
$ /usr/bin/gtest-config --version
1.8.0
This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 25 September 2018, 22:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.8.1-2
Comment by Eli Schwartz (eschwartz) - Wednesday, 12 September 2018, 13:42 GMT
  • Field changed: Summary ([gtest] PLEASE ENTER SUMMARY → [gtest] reports the wrong version)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages → Upstream Bugs)
  • Task assigned to Levente Polyak (anthraxx), Felix Yan (felixonmars)
This happened because upstream released a new version but did not update the version number in their code. In fact their configure.ac *still* reports itself as 1.8.0 on master.

Please ask them to fix their code and be more careful next time. It's not the first time they goofed like this.
Comment by Levente Polyak (anthraxx) - Tuesday, 25 September 2018, 22:03 GMT
upstreamed the correct versions, however we dont quite care anymore as i added a prepare stage to unfuck the versions whatever they package :P

Loading...