Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60015 - [texlive-core] 2018.48566-1 Texdoc fails because texlive.tlpdb does not exist.

Attached to Project: Arch Linux
Opened by Bart De Roy (sharethewisdom) - Tuesday, 11 September 2018, 10:45 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 13 September 2018, 01:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Running texdoc fails with this error:

[string "/usr/share/texmf-dist/scripts/texdoc/search.t..."]:569: assertion failed!

...because texlive.tlpdb should be packaged. see
https://github.com/TeX-Live/texdoc/issues/20

Additional info:
$ uname -a
Linux libreboot 4.18.5-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 24 12:48:58 UTC 2018 x86_64 GNU/Linux
$ pacman -Qi texlive-core|grep Version
Version : 2018.48566-1

Reproduce:
$ texdoc --debug cjhebrew`
https://pastebin.com/raw/syWWNdVk
$ pacman -Ql texlive-core|grep tlpdb
texlive-core /usr/share/texmf-dist/scripts/texlive/lua/texlive/tlpdb.tlu
texlive-core /usr/share/texmf-dist/scripts/texlive/test-tlpdb.tlu

the file should probably be installed as /usr/share/tlpkg/texlive.tlpdb
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 13 September 2018, 01:36 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#60013 don't open nearly-identical duplicates of your own bug just to add some information you added in a comment anyway

Loading...