Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60012 - [avahi] Avahi DBus service not found when Avahi is not running

Attached to Project: Arch Linux
Opened by Ludovico (Arcmuly) - Tuesday, 11 September 2018, 10:08 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 15 September 2018, 04:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
This bug is the same as #42638 that was marked as fixed 4 years ago but apparently that problem is presenting again.

If we send a DBus message to org.freedesktop.Avahi when avahi-daemon.service is not running we will get an error "Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory" because usr/share/dbus-1/system-services/org.freedesktop.Avahi.service tries to start the dbus-org.freedesktop.Avahi.service systemd service that is not available.

To solve this there should be a symlink of /usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service to /usr/lib/systemd/system/avahi-daemon.service.

Additional info:
* avahi 0.7+16+g1cc2b8e-2

Steps to reproduce:
with avahi not running execute `$ dbus-send --system --print-reply --type=method_call --dest=org.freedesktop.Avahi / org.freedesktop.Avahi.Server.GetHostName`
The output will be "Error org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.Avahi.service not found."

This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 15 September 2018, 04:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is on purpose. https://git.archlinux.org/svntogit/packa ges.git/commit/trunk?h=packages/avahi&am p;id=d39a606f47b68707c9df59d9474d063a47a 0ce61

Loading...