Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59963 - Failure in wireless LAN in EliteBook 2760p

Attached to Project: Arch Linux
Opened by Jorge Recalde (jorgelrm) - Thursday, 06 September 2018, 21:53 GMT
Last edited by Jan de Groot (JGC) - Friday, 14 September 2018, 21:32 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading to 4.18.6 kernel wireless networking messed up. Things get back to normal when reverting to 4.18.5 version.
In dmesg log, this is what appears:


[ 10.423720] iwlwifi 0000:24:00.0: Radio type=0x1-0x2-0x0
[ 10.712536] iwlwifi 0000:24:00.0: Radio type=0x1-0x2-0x0
[ 10.792881] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[ 41.007204] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[ 43.143384] iwlwifi 0000:24:00.0: Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms.
[ 43.143394] iwlwifi 0000:24:00.0: Current CMD queue read_ptr 44 write_ptr 45
[ 43.143457] iwlwifi 0000:24:00.0: Loaded firmware version: 18.168.6.1
[ 43.143625] iwlwifi 0000:24:00.0: 0x00000000 | OK
[ 43.143629] iwlwifi 0000:24:00.0: 0x00000000 | uPc
[ 43.143634] iwlwifi 0000:24:00.0: 0x00000000 | branchlink1
[ 43.143638] iwlwifi 0000:24:00.0: 0x00000000 | branchlink2
[ 43.143642] iwlwifi 0000:24:00.0: 0x00000000 | interruptlink1
[ 43.143646] iwlwifi 0000:24:00.0: 0x00000000 | interruptlink2
[ 43.143650] iwlwifi 0000:24:00.0: 0x00000000 | data1
[ 43.143654] iwlwifi 0000:24:00.0: 0x00000000 | data2
[ 43.143658] iwlwifi 0000:24:00.0: 0x00000000 | line
[ 43.143662] iwlwifi 0000:24:00.0: 0x00000000 | beacon time
[ 43.143666] iwlwifi 0000:24:00.0: 0x00000000 | tsf low
[ 43.143670] iwlwifi 0000:24:00.0: 0x00000000 | tsf hi
[ 43.143674] iwlwifi 0000:24:00.0: 0x00000000 | time gp1
[ 43.143678] iwlwifi 0000:24:00.0: 0x00000000 | time gp2
[ 43.143682] iwlwifi 0000:24:00.0: 0x00000000 | time gp3
[ 43.143686] iwlwifi 0000:24:00.0: 0x00000000 | uCode version
[ 43.143690] iwlwifi 0000:24:00.0: 0x00000000 | hw version
[ 43.143694] iwlwifi 0000:24:00.0: 0x00000000 | board version
[ 43.143698] iwlwifi 0000:24:00.0: 0x00000000 | hcmd
[ 43.143702] iwlwifi 0000:24:00.0: 0x00000000 | isr0
[ 43.143706] iwlwifi 0000:24:00.0: 0x00000000 | isr1
[ 43.143710] iwlwifi 0000:24:00.0: 0x00000000 | isr2
[ 43.143714] iwlwifi 0000:24:00.0: 0x00000000 | isr3
[ 43.143718] iwlwifi 0000:24:00.0: 0x00000000 | isr4
[ 43.143722] iwlwifi 0000:24:00.0: 0x00000000 | isr_pref
[ 43.143726] iwlwifi 0000:24:00.0: 0x00000000 | wait_event
[ 43.143730] iwlwifi 0000:24:00.0: 0x00000000 | l2p_control
[ 43.143734] iwlwifi 0000:24:00.0: 0x00000000 | l2p_duration
[ 43.143738] iwlwifi 0000:24:00.0: 0x00000000 | l2p_mhvalid
[ 43.143742] iwlwifi 0000:24:00.0: 0x00000000 | l2p_addr_match
[ 43.143746] iwlwifi 0000:24:00.0: 0x00000000 | lmpm_pmg_sel
[ 43.143750] iwlwifi 0000:24:00.0: 0x00000000 | timestamp
[ 43.143754] iwlwifi 0000:24:00.0: 0x00000000 | flow_handler
[ 43.143869] iwlwifi 0000:24:00.0: Start IWL Event Log Dump: nothing in log
[ 43.143891] iwlwifi 0000:24:00.0: Command REPLY_RXON failed: FW Error
[ 43.143896] iwlwifi 0000:24:00.0: Error clearing ASSOC_MSK on BSS (-5)
[ 43.155919] ieee80211 phy0: Hardware restart was requested
[ 43.162503] iwlwifi 0000:24:00.0: Radio type=0x1-0x2-0x0
[ 43.454760] iwlwifi 0000:24:00.0: Radio type=0x1-0x2-0x0
[ 43.538234] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[ 43.545308] iwlwifi 0000:24:00.0: Radio type=0x1-0x2-0x0

Maybe a firmware compiling error?


Additional info:
Kernels used: 4.18.6 (upgraded 09-06) and 4.18.5 (using since 09-03)


Steps to reproduce:
Upgrade to 4.18.6 kernel and restart (immediate failure)
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 14 September 2018, 21:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  " After upgrading to kernel 4.18.8 all errors dissapeared without intervention. "

Loading...