Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59925 - [python-matplotlib] python-matplotlib should not depend on libxkbcommon-x11

Attached to Project: Community Packages
Opened by Antony Lee (anntzer) - Tuesday, 04 September 2018, 14:30 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Wednesday, 24 October 2018, 13:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
A dependency of python-matplotlib on libxkbcommon-x11 was added in 1.4.0-3 in order to fix https://bugs.archlinux.org/task/42307 (namely, libxkbcommon-x11 was needed to make the default qt5agg backend work, but qt5-base only optdepended on libxkbcommon-x11 rather than depending on it).
qt5-base now has a strict dependency on libxkbcommon-x11 (at least since 5.6.0rc-1, which is the oldest version that asp gives me), so python-matplotlib doesn't need to depend anymore on libkxbcommon-x11 (which it doesn't "really" depend on anyways, for example for backends other than the qt-based ones).

Additional info:
* package version(s): See above.
* config and/or log files etc.: N/A

Steps to reproduce:
N/A
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Wednesday, 24 October 2018, 13:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-matplotlib 3.0.0-1 & python2-matplotlib 2.2.3-3.

Loading...