Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59903 - [ntfs-3g] Enable xattr mapping

Attached to Project: Arch Linux
Opened by Chris luna (chris_l) - Sunday, 02 September 2018, 05:58 GMT
Last edited by Gaetan Bisson (vesath) - Saturday, 15 September 2018, 22:51 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The mount option "streams_interface=xattr", along with a .NTFS-3G/XattrMapping file allows to copy files along with their NTFS attributes using standard tools (like rsync, tar and cp). The documentation of how that feature works is here: https://www.tuxera.com/community/ntfs-3g-advanced/extended-attributes/

However, for that option to be available, is necessary to add "--enable-xattr-mappings" to the configure script.
So my feature request is; to add the "--enable-xattr-mappings" flag to the call to "./configure" on the PKGBUILD.

I have used the official PKGBUILD, added the flag and compiled it, and it seems to be working without problems.


Additional info:
* package version(s): The current version at this moment, 2017.3.23


Steps to reproduce:

Just add --enable-xattr-mappings after line 38 on the PKGBUILD and build the package. Follow the instructions about extended-attributes here: https://www.tuxera.com/community/ntfs-3g-advanced/extended-attributes/
This task depends upon

Closed by  Gaetan Bisson (vesath)
Saturday, 15 September 2018, 22:51 GMT
Reason for closing:  Implemented
Additional comments about closing:  ntfs-3g-2017.3.23-2 in [extra]

Loading...