Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#59865 - [upower] After upgrade to 0.99.8-1, automatic keyboard backlight brightness does not work

Attached to Project: Arch Linux
Opened by Konstantin Y (tm4ig) - Wednesday, 29 August 2018, 19:57 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 12 September 2018, 21:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


After upgrade upower package to 0.99.8-1 version do not work automatic keyboard backlight brightness adjustment on Dell Inspiron 15 5567.
With upower 0.99.7-1 everything is fine.
Kernel version 4.18.5
Systemd version 239
DE version KDE 5.13.4
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 12 September 2018, 21:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.99.8-2
Comment by D.T. (MountainX) - Thursday, 30 August 2018, 01:19 GMT
I am experiencing this issue with multiple Lenovo ThinkPads. I'm running Arch with KDE. My symptoms are that the keyboard backlight does not come on. Furthermore, in KDE's System Settings > Power settings, there is no longer a setting for keyboard backlight.
Comment by Stefano Campanella (stefanocampanella) - Thursday, 30 August 2018, 06:54 GMT Comment by Max Resch (mxr) - Thursday, 30 August 2018, 22:00 GMT
Upstream says the culprit is the systemd-unit by setting PrivateNetwork=true is tested this with systemctl edit upower.service and noticed that setting ProtectKernelTunables=false actually works.
Comment by D.T. (MountainX) - Friday, 31 August 2018, 02:30 GMT
mxr said:
> setting ProtectKernelTunables=false actually works.

This works for me on a Lenovo ThinkPad Yoga 370
Comment by Antonio Gutierrez (chibby0ne) - Friday, 31 August 2018, 15:00 GMT
> setting ProtectKernelTunables=false actually works.

I tried this and it didn't work for me in a Asus Zenbook UX330.

Also the upstream issue was separated from the previous one, now it lives here:
Comment by Eric Donkersloot (lordchaos) - Friday, 07 September 2018, 20:32 GMT
The following workaround actually works for me:

sudo -E systemctl edit upower.service

Insert the following lines:

RestrictAddressFamilies=AF_UNIX AF_NETLINK
Comment by D.T. (MountainX) - Friday, 07 September 2018, 20:43 GMT
Only two different laptops, I have only needed "ProtectKernelTunables=false"

systemctl edit upower.service

However, what are the security implications of this? Is there a more security-friendly solution?
Comment by D.T. (MountainX) - Friday, 07 September 2018, 20:45 GMT
BTW, in my experience, you have to actually reboot for the change to take effect. (Seems logical if this is a change affecting kernel parameters.)
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 11 September 2018, 04:06 GMT
On MacBookAir7,2, changing only PrivateNetwork=false is enough to make upower work again.
Comment by Travis (haggishunk) - Tuesday, 11 September 2018, 05:24 GMT
@D.T. (MountainX) a simple service restart worked for me

sudo systemctl restart upower.service