Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59858 - Botched filesystem update screwed my system

Attached to Project: Arch Linux
Opened by Johannes Jordan (FoPref) - Wednesday, 29 August 2018, 09:38 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 29 August 2018, 13:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I had symlinked /var/cache to another partition which is a RAID0 array instead of root partition which is a RAID1.

Upon pacman -Syu, after tzdata was updated, it tried to update filesystem but complained that it could not find /var/cache/pacman/pkg/filesystem-2018.8-1-x86_64.pkg.tar.xz and stopped the update.

In fact, now my symlink is gone. So is /[s]?bin /lib(64)? /usr/sbin, /var/mail, /var/run, /etc/arch-release, /etc/profile.d/locale.sh, /usr/lib/os-release, basically all the files that are part of filesystem package (https://www.archlinux.org/packages/core/x86_64/filesystem/files/ not grey) and were not manually edited.

Also, I cannot execute _any_ command:

Failed to execute process '/usr/bin/test'. Reason:
The file '/usr/bin/test' does not exist or could not be executed.
Failed to execute process '/usr/bin/ls'. Reason:
The file '/usr/bin/ls' does not exist or could not be executed.

However /usr/bin/ls seems to still be there.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 29 August 2018, 13:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#50298
Comment by Johannes Jordan (FoPref) - Wednesday, 29 August 2018, 09:53 GMT
I can still execute binaries using /usr/lib/ld-linux-x86-64.so.2 so I assume the missing /lib is the cause of not being able to execute anything.
Comment by nl6720 (nl6720) - Wednesday, 29 August 2018, 09:59 GMT
A duplicate of FS#50298 ?
Comment by Johannes Jordan (FoPref) - Wednesday, 29 August 2018, 12:07 GMT
This fucked up my system and repair is really nasty, even from chroot pacman cannot re-install filesystem package because /etc/mtab is missing etc.

I really don't understand how one can close this bug without resolution and let people constantly run into the open knive again, e.g. see https://bbs.archlinux.org/viewtopic.php?id=228220
Comment by Eli Schwartz (eschwartz) - Wednesday, 29 August 2018, 13:33 GMT
It is a really, really, really bad idea to overwrite packaged directories with symlinks. Use a bind mount instead.

Loading...