Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59833 - [linux] bpfilter prevents umounting rootfs

Attached to Project: Arch Linux
Opened by Olivier Brunel (jjacky) - Monday, 27 August 2018, 16:37 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 03 September 2018, 19:15 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Starting with kernel 4.18 a new & still experimental feature has been enabled via CONFIG_BPFILTER, however this seems to be causing some issues. Specifically, as part of its expected behavior the kernel creates a new process to exec some bpfilter helper, which is required for things to work properly. Problem is, said helper will have references/fds to the rootfs making it impossible to umount said fs on shutdown.

I'm not sure what is needed to reproduce it, maybe this doesn't happen on every system, but on my system every boot with a 4.18.x kernel will result in this issue manifesting. I've also tried blacklisting the bpfilter module, however that's not possible because while then the helper isn't spawned, lots of other things (e.g. iptables-restore, etc) will just fail.

As a result, and considering this whole bpfilter feature is still experimental, I would suggest disabling CONFIG_BPFILTER, at least for now/until this is fixed.

Note that the issue has been reported upstream[1].


[1] https://www.spinics.net/lists/netdev/msg520030.html
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 03 September 2018, 19:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk; thanks.
Comment by Tommy Schmitt (spinka) - Tuesday, 28 August 2018, 12:48 GMT
Quote from the author of bpfilter:

"it's not required. It's not doing anything useful at the moment
and defaults to 'n' in kconfig. Please disable it your kernel."

https://marc.info/?l=linux-netdev&m=153542730925638&w=2

Considering above CONFIG_BPFILTER should be disabled in Arch kernels.

Loading...