Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59824 - [linux] hctosys: unable to open rtc device (rtc0)

Attached to Project: Arch Linux
Opened by Stefan Jensen (sjensen) - Monday, 27 August 2018, 09:55 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 31 August 2018, 07:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Kernel complains about a non existing rtc device on early boot.
System clock may not set on early boot.

Additional info:

* package version(s)

"linux 4.18.5.arch1-1" on a "LENOVO ThinkPad X200 7454CTO"

* config and/or log files etc.

$dmesg |grep rtc

[ 0.428021] hctosys: unable to open rtc device (rtc0)
[ 2.492609] rtc_cmos 00:02: RTC can wake from S4
[ 2.499205] rtc_cmos 00:02: registered as rtc0
[ 2.499250] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram, hpet irqs

$grep -i "hctosys" /usr/src/linux-4.18.5.arch1/.config

CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"

$grep -i "cmos" /usr/src/linux-4.18.5.arch1/.config

CONFIG_GENERIC_CMOS_UPDATE=y
CONFIG_RTC_DRV_CMOS=m

$lsmod|grep rtc
rtc_cmos 24576 1

Steps to reproduce:

Boot "linux 4.18.5.arch1-1" and check dmesg.

This is imo caused by "CONFIG_RTC_DRV_CMOS=m" in the corresponding
kernel .config and could be avoided by setting "CONFIG_RTC_DRV_CMOS=y".

Output with "CONFIG_RTC_DRV_CMOS=y" on my custom kernel:

$dmesg |grep rtc
[ 0.401081] rtc_cmos 00:02: RTC can wake from S4
[ 0.401315] rtc_cmos 00:02: registered as rtc0
[ 0.401338] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[ 0.414801] rtc_cmos 00:02: setting system clock to 2018-08-27 09:05:06 UTC (1535360706)

Please consider changing "CONFIG_RTC_DRV_CMOS=m" to "CONFIG_RTC_DRV_CMOS=y".
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 31 August 2018, 07:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk; thanks.

Loading...