Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59823 - [kibana] After update to 6.4.0 Kibana fails to start due to wrong nodejs version

Attached to Project: Community Packages
Opened by Michael Kogan (Photon) - Monday, 27 August 2018, 09:43 GMT
Last edited by Massimiliano Torromeo (mtorromeo) - Tuesday, 18 September 2018, 15:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Massimiliano Torromeo (mtorromeo)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After the update to 6.4.0 Kibana fails to start and I see the following line in the journal:

Kibana does not support the current Node.js version v10.9.0. Please use Node.js v8.11.4.

I installed nodejs-lts-carbon instead of nodejs and Kibana started up. I am wondering how it worked with Kibana 6.3.2 though, afaik I had nodejs 10.9.0 installed and it still worked...
This task depends upon

Closed by  Massimiliano Torromeo (mtorromeo)
Tuesday, 18 September 2018, 15:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  kibana-6.4.0-2
Comment by Massimiliano Torromeo (mtorromeo) - Monday, 27 August 2018, 17:00 GMT
I don't know if kibana 6.3.2 worked just by accident or if it mostly works with nodejs 10 but with bugs in some specific places.
The fact is that the nodejs version check was introduced upstream in kibana 6.4 and I don't think I am supposed to remove it... I may add a requirement to nodejs<10 in the PKGBUILD.
Comment by Michael Kogan (Photon) - Monday, 27 August 2018, 19:55 GMT
Sounds good!
Comment by Maxym Synytsky (Synchrotron) - Tuesday, 18 September 2018, 13:05 GMT
nodejs-lts-carbon has bumped to 8.12.0 and Kibana does not work with it any more.
Comment by Jeremy M. (jskier) - Tuesday, 18 September 2018, 13:11 GMT
You need to hold the lts package at 8.11 (get it from rollback if needed).

IMO, the fact that kibana isn't keeping up with nodejs-lts stable is an upstream issue.
Comment by Massimiliano Torromeo (mtorromeo) - Tuesday, 18 September 2018, 15:02 GMT
I've removed the nodejs version check inside kibana and made the package depend on nodejs-lts-carbon

Loading...