Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59817 - VirtualBox additions: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type

Attached to Project: Arch Linux
Opened by Jozef Babjak (cronin) - Monday, 27 August 2018, 06:33 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 27 August 2018, 06:37 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After some of the package updates which happened during the last month, it is not possible to install virtual box guest additions anymore. Without those, I cannot use host-guest shared drive. An attempt to install the additions shows the following messages; the full log file is attached:



[root@archer][~][08:24:50] ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.18 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 5.2.18 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules. This may take a while.
VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what went wrong
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: modprobe vboxsf failed
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 27 August 2018, 06:37 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Whatever VBoxLinuxAdditions.run is, it's not Arch.

Loading...