Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59810 - new problems with update containing mesa-18.1.7 with nvidia (nouveau) card vga monitor stays asleep

Attached to Project: Arch Linux
Opened by Richard PALO (risto3) - Sunday, 26 August 2018, 07:08 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 16 April 2020, 06:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:
Since the recent upgrade (2018-08-24) to mesa-18.1.7 from mesa-18.1.6
(it may well be due to something else) my nVidia VGA (nouveau) connected monitor quickly goes to sleep
and never wakes up, only the HDMI connected monitor remains normally active.

No manual changes were made, only a system upgrade (pacman -Syu).

BTW - I'm running lightdm/lxqt

Prior, both monitors were always active until the screen saver kicked in.

Additional info:
* package version(s)
* config and/or log files etc.

These files are updated since 2018-08-24:
lightdm-1:1.26.0-2-x86_64.pkg.tar.xz
linux-firmware-20180821.1d17c18-3-any.pkg.tar.xz
mesa-18.1.7-1-x86_64.pkg.tar.xz
mesa-vdpau-18.1.7-1-x86_64.pkg.tar.xz
wayland-1.16.0-1-x86_64.pkg.tar.xz

xf86-video-nouveau-1.0.15-3-x86_64.pkg.tar.xz

Steps to reproduce:
configure hdmi screen to primary left, vga to secondary right.

Xorg.0.log attached
This task depends upon

Comment by Richard PALO (risto3) - Sunday, 26 August 2018, 07:11 GMT
xorg.0.log
Comment by Richard PALO (risto3) - Sunday, 26 August 2018, 10:46 GMT
Hmm, this seems to be a quirk involving lxqt.
I disconnected and changed to lxde where I needed to reconfigure VGA-2 to the right of HDMI-1.
Thought I'd check lxqt again, and so far, things seems okay.... something was probably overwriting some bits somewhere.
I'll give it 24 hours to see if it reappears and report back.
Comment by Richard PALO (risto3) - Sunday, 26 August 2018, 12:09 GMT
nah, didn't last more than a few minutes...
since, I updated to linux-4.18.5 and rebooted.
No luck in getting back VGA-2.
If I power the monitor off then back on, it flickers a window for a second
then blanks back out and stays such.
Truly frustrating (and noticeable I've become quite dependent upon multiple monitors).
Any hints to try?
Comment by Caleb Reister (calebreister) - Monday, 24 December 2018, 20:43 GMT
I'm having similar issues on my laptop with an HDMI monitor. However, I'm running SDDM + KDE with integrated graphics, and use Bumblebee/primus when I want to use the NVIDIA GPU. Unfortunately, my usual fix (deleting .Xauthority) is not helping. Your report leads me to believe that the problem has more to do with Xorg/mesa than the video drivers.
Comment by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 11:15 GMT
Is this still an issue?
Comment by Daniel Bershatsky (daskol) - Tuesday, 14 January 2020, 11:33 GMT
External monitor (via HDMI) is not detected with mesa-19.3.2-2 but is detected with mesa-19.3.2-1. This is a kind of floating bug since December, 2019.

Loading...