Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59736 - blueman 2.0.6 prompts for root password on login

Attached to Project: Arch Linux
Opened by James Bunton (delx) - Tuesday, 21 August 2018, 13:23 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 21 August 2018, 22:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading to blueman 2.0.6 I get prompted for my root password when logging in to an XFCE session from lightdm.

It seems that a new rule needs to be added in /etc/polkit-1/rules.d/

See:
- https://github.com/blueman-project/blueman/wiki/PolicyKit
- https://bbs.archlinux.org/viewtopic.php?id=239697

Thanks :)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 21 August 2018, 22:57 GMT
Reason for closing:  Not a bug
Comment by Balló György (City-busz) - Tuesday, 21 August 2018, 15:03 GMT
This is an upstream decision. The default rules are specified in /usr/share/polkit-1/actions/org.blueman.policy . You can override it yourself in /etc/polkit-1/rules.d/ .
Comment by James Bunton (delx) - Tuesday, 21 August 2018, 22:46 GMT
Fair enough. This isn't a packaging issue :)

I've raised an issue with blueman asking them to reconsider the default policy: https://github.com/blueman-project/blueman/issues/912

Thanks.

Loading...