Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59719 - [libssh] 0.8.1 breaks amarok

Attached to Project: Arch Linux
Opened by Fabian Maurer (DarkShadow44) - Sunday, 19 August 2018, 15:18 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 30 August 2018, 08:07 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Amarok errors on start, rendering it completely unsable. It show an error message with
"The amarok database reported the following errors:
MySQLe something failed! on library initialization failed, return code 1
In most cases you will need to resolve these errors before Amarok will run properly"

Additional info:
amarok 2.9.0-2
mariadb 10.1.35-1
kdebase-runtime 17.08.3-3
ffmpeg 1:4.0.2-2

I already tried deleting ".kde4/share/apps/amarok/" to get rid of the config, but that didn't help

"amarok -d --nofork" log attached

Steps to reproduce:
Try to run amarok on an up-to-date system

This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 30 August 2018, 08:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  worked around in 0.8.1-2 (plus amarok no longer supported)
Comment by Antonio Rojas (arojas) - Monday, 20 August 2018, 15:36 GMT
No idea what may be causing this, downgrading mariadb doesn't seem to help. Can you tell when did this start?
Comment by Fabian Maurer (DarkShadow44) - Monday, 20 August 2018, 18:08 GMT
I'm afraid not. I tried downgrading, but couldn't get it to work.
Comment by Antonio Rojas (arojas) - Monday, 20 August 2018, 20:46 GMT
Are you on [testing]?
Comment by Fabian Maurer (DarkShadow44) - Monday, 20 August 2018, 20:48 GMT
Yes, I am. Sorry, completely forgot to mention.
Comment by Antonio Rojas (arojas) - Monday, 20 August 2018, 21:41 GMT
This must be the most misleading error message ever.

Anyway, it's libssh 0.8.1 that's causing this. I still have no idea why, neither amarok nor mariadb use libssh at all. It's only linked to it via ffmpeg. Rebuilding ffmpeg with libssh doesn't fix the issue, building without libssh does. The only thing I can think of is that libssh 0.8.1 adds some symbol that conflicts with some other library that amarok links to.
Comment by Antonio Rojas (arojas) - Tuesday, 21 August 2018, 09:01 GMT
I've brought it up on the upstream mailing list https://www.libssh.org/archive/libssh/2018-08/0000032.html

As a workaround 0.8.1-2 switches to libgcrypt instead of openssl.
Comment by Fabian Maurer (DarkShadow44) - Tuesday, 21 August 2018, 18:12 GMT
Thanks, 0.8.1-2 fixes the issue for me.
Though I needed to test with amarok 2.9.0-2, since there was a new amarok release (2.9.0.git20180816-1) which has another issue, see #59739.

Loading...