Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59698 - [linux] Wireless mouse movements have stopped working

Attached to Project: Arch Linux
Opened by Moacir Candido (guerra405) - Friday, 17 August 2018, 22:27 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 13 September 2018, 01:53 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After upgrading to version 4.18.1-arch wireless mouse movements have stopped working, both wireless and bluetooth, works only click and scroll. Wired mouse keep running. I tested with a lot types of mouses.


Additional info:
* package version(s)
* config and/or log files etc.
linux 4.18.1-arch

Steps to reproduce:
Just try move wireless mouse.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 13 September 2018, 01:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.18.6.arch1-1
Comment by loqs (loqs) - Friday, 17 August 2018, 22:54 GMT
What is dmesg output for both 4.18.1-arch and the old kernel without the issue?
Comment by Moacir Candido (guerra405) - Friday, 17 August 2018, 23:17 GMT
Sorry. I can't use the old kernel, I can use only the new kernel 4.18.1.

Using a Wireless Xiaomi Mi Mouse:

[ 122.295608] usb 1-1.3: new full-speed USB device number 5 using ehci-pci
[ 122.397842] usb 1-1.3: New USB device found, idVendor=2717, idProduct=003b, bcdDevice= 0.01
[ 122.397849] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 122.397854] usb 1-1.3: Product: MI Wireless Mouse
[ 122.397857] usb 1-1.3: Manufacturer: MI Dongle
[ 122.403300] input: MI Dongle MI Wireless Mouse as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:2717:003B.000C/input/input46
[ 122.459627] hid-generic 0003:2717:003B.000C: input,hidraw0: USB HID v1.11 Keyboard [MI Dongle MI Wireless Mouse] on usb-0000:00:1d.0-1.3/input0
[ 122.463003] input: MI Dongle MI Wireless Mouse Mouse as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:2717:003B.000D/input/input47
[ 122.463398] input: MI Dongle MI Wireless Mouse Mouse as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:2717:003B.000D/input/input48
[ 122.463617] input: MI Dongle MI Wireless Mouse Consumer Control as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:2717:003B.000D/input/input49
[ 122.519810] hid-generic 0003:2717:003B.000D: input,hidraw1: USB HID v1.11 Mouse [MI Dongle MI Wireless Mouse] on usb-0000:00:1d.0-1.3/input1
[ 122.523162] input: MI Dongle MI Wireless Mouse Consumer Control as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.2/0003:2717:003B.000E/input/input50
[ 122.579336] input: MI Dongle MI Wireless Mouse Keyboard as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.2/0003:2717:003B.000E/input/input51
[ 122.579719] hid-generic 0003:2717:003B.000E: input,hiddev0,hidraw2: USB HID v1.11 Keyboard [MI Dongle MI Wireless Mouse] on usb-0000:00:1d.0-1.3/input2
[ 122.581766] hid-generic 0003:2717:003B.000F: hiddev1,hidraw3: USB HID v1.10 Device [MI Dongle MI Wireless Mouse] on usb-0000:00:1d.0-1.3/input3



Using a Wireless Maxprint Mouse n' Keyboard:

[ 347.649745] usb 1-1.3: new low-speed USB device number 6 using ehci-pci
[ 347.843176] usb 1-1.3: New USB device found, idVendor=0e8f, idProduct=00a5, bcdDevice= 3.11
[ 347.843184] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 347.843188] usb 1-1.3: Product: 2.4G RX
[ 347.843192] usb 1-1.3: Manufacturer: DaKai
[ 347.847622] input: DaKai 2.4G RX as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:0E8F:00A5.0010/input/input52
[ 347.903747] hid-generic 0003:0E8F:00A5.0010: input,hidraw0: USB HID v1.10 Keyboard [DaKai 2.4G RX] on usb-0000:00:1d.0-1.3/input0
[ 347.910927] input: DaKai 2.4G RX Mouse as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:0E8F:00A5.0011/input/input53
[ 347.911383] input: DaKai 2.4G RX System Control as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:0E8F:00A5.0011/input/input54
[ 347.966874] input: DaKai 2.4G RX Consumer Control as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:0E8F:00A5.0011/input/input55
[ 347.967176] input: DaKai 2.4G RX as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:0E8F:00A5.0011/input/input56
[ 347.967667] hid-generic 0003:0E8F:00A5.0011: input,hiddev0,hidraw1: USB HID v1.10 Mouse [DaKai 2.4G RX] on usb-0000:00:1d.0-1.3/input1



Using a Wired Generic USB Mouse:

[ 504.566340] usb 1-1.3: new low-speed USB device number 7 using ehci-pci
[ 504.667335] usb 1-1.3: New USB device found, idVendor=0101, idProduct=0007, bcdDevice= 1.00
[ 504.667342] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[ 504.667346] usb 1-1.3: Product: USB OPTICAL MOUSE
[ 504.671257] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:0101:0007.0012/input/input58
[ 504.671680] hid-generic 0003:0101:0007.0012: input,hidraw0: USB HID v1.11 Mouse [USB OPTICAL MOUSE ] on usb-0000:00:1d.0-1.3/input0



I have instaled xf86-input-mouse and tried install xf86-input-evdev but without success because not works.
Comment by Wael Nasreddine (kalbasit) - Saturday, 18 August 2018, 03:00 GMT
I'm having the same issue (duplicate task  FS#59699 ). I've also filed a bug upstream https://bugs.archlinux.org/task/59698
Comment by Wael Nasreddine (kalbasit) - Saturday, 18 August 2018, 03:59 GMT
I can also replicate the issue on kernel 4.18.2.
Comment by Vyacheslav Konovalov (vyachkonovalov) - Monday, 20 August 2018, 11:33 GMT
The same issue on kernel 4.18.3
Comment by Vyacheslav Konovalov (vyachkonovalov) - Monday, 20 August 2018, 12:39 GMT
Found a temporary fix (with MiMouse in my case):
In /usr/lib/udev/rules.d/70-mouse.rules before line
ENV{ID_INPUT_MOUSE}=="", GOTO="mouse_end"
add
ATTRS{name}=="MiMouse Mouse", ENV{ID_INPUT_MOUSE}="1"
and then switch off the mouse, run
# systemctl restart bluetooth
(or restart the system) switch on the mouse, it should work.

Attribute name="MiMouse Mouse" I've got from
# udevadm info -a -n /dev/input/event19
and device name "/dev/input/event19" from
# evtest
Comment by Travis Hume (travishume) - Monday, 20 August 2018, 17:48 GMT
My Kingston Expert Wireless trackball is also affected. No pointer movement under kernel 4.18.3.arch1-1.
I've attached the bluetooth journalctl output for working (4.17.11-6-ck) and broken (4.18.3.arch1-1).
Comment by A. Bosch (progandy) - Friday, 24 August 2018, 09:40 GMT
Upstream bug reports describing the same issues with some USB mice and trackballs.
https://bugzilla.kernel.org/show_bug.cgi?id=200847
https://bugzilla.kernel.org/show_bug.cgi?id=200849
Comment by Leif Huhn (volfyd) - Friday, 24 August 2018, 16:45 GMT Comment by Moacir Candido (guerra405) - Sunday, 02 September 2018, 19:22 GMT
Following the tip of the user Vyacheslav Konovalov (vyachkonovalov):
------------------------------------------------------------------------------
Found a temporary fix (with MiMouse in my case):
In /usr/lib/udev/rules.d/70-mouse.rules before line
ENV{ID_INPUT_MOUSE}=="", GOTO="mouse_end"
add
ATTRS{name}=="MiMouse Mouse", ENV{ID_INPUT_MOUSE}="1"
and then switch off the mouse, run
# systemctl restart bluetooth
(or restart the system) switch on the mouse, it should work.
------------------------------------------------------------------------------
You can use for any wireless mouse, to do this just connect your wireless mouse usb or bluetootn, run dmesg and locate the last line that have "hid-generic" and copy the name between [ ] e.g. [MI Dongle MI Wireless Mouse] then fallow the steps above adding ATTRS{name}=="MI Dongle MI Wireless Mouse Mouse", ENV{ID_INPUT_MOUSE}="1" in the file /usr/lib/udev/rules.d/70-mouse.rules before the line ENV{ID_INPUT_MOUSE}=="", GOTO="mouse_end". Remember, you need add "Mouse" after your mouse ID e.g. "MI Dongle MI Wireless Mouse Mouse".

You can add how many wireless mouses you want.

E.g. For Xiaomi Mi Mouse usb and bluetooth connections:
ACTION=="remove", GOTO="mouse_end"
KERNEL!="event*", GOTO="mouse_end"
ATTRS{name}=="MiMouse Mouse", ENV{ID_INPUT_MOUSE}="1"
ATTRS{name}=="MI Dongle MI Wireless Mouse Mouse", ENV{ID_INPUT_MOUSE}="1"
ENV{ID_INPUT_MOUSE}=="", GOTO="mouse_end"

Thank's to Vyacheslav Konovalov (vyachkonovalov).
Comment by Wael Nasreddine (kalbasit) - Tuesday, 04 September 2018, 20:59 GMT
This has been fixed upstream in the https://patchwork.kernel.org/patch/10587369/ patch. I've submitted a fix to NixOS that fixes this: https://github.com/NixOS/nixpkgs/pull/46061 This can be fixed by applying the patch to core/linux.
Comment by loqs (loqs) - Tuesday, 04 September 2018, 22:05 GMT Comment by Ranieri Althoff (rsa) - Tuesday, 11 September 2018, 05:35 GMT
Can this patch be added in 4.18 package? Wireless mouses are very common and it is very unfortunate to wait until 4.19 using 4.17 to avoid the issue.
Comment by loqs (loqs) - Tuesday, 11 September 2018, 09:58 GMT

Loading...