Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59630 - [hunspell-en_{AU,CA,GB,US}] file conflicts with hunspell-en

Attached to Project: Arch Linux
Opened by jason ryan (jasonwryan) - Monday, 13 August 2018, 04:17 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 15 August 2018, 17:21 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Upgrading hunspell-en_AU and the associated packages that have been split out (CA,GB,US) from 2018.04.16-2 2018.04.16-3 fails with file conflicts:

hunspell-en_AU: /usr/share/hunspell/en_AU.aff exists in filesystem (owned by hunspell-en)
hunspell-en_AU: /usr/share/hunspell/en_AU.dic exists in filesystem (owned by hunspell-en)
hunspell-en_AU: /usr/share/myspell/dicts/en_AU.aff exists in filesystem (owned by hunspell-en)
hunspell-en_AU: /usr/share/myspell/dicts/en_AU.dic exists in filesystem (owned by hunspell-en)
hunspell-en_CA: /usr/share/hunspell/en_CA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_CA: /usr/share/hunspell/en_CA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_CA: /usr/share/myspell/dicts/en_CA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_CA: /usr/share/myspell/dicts/en_CA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_AG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_AG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BS.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BS.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BW.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BW.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BZ.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_BZ.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_DK.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_DK.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_GB.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_GB.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_GH.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_GH.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_HK.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_HK.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_IE.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_IE.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_IN.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_IN.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_JM.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_JM.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NZ.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_NZ.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_SG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_SG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_TT.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_TT.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_ZA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_ZA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_ZW.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/hunspell/en_ZW.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_AG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_AG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BS.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BS.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BW.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BW.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BZ.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_BZ.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_DK.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_DK.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_GB.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_GB.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_GH.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_GH.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_HK.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_HK.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_IE.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_IE.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_IN.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_IN.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_JM.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_JM.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NZ.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_NZ.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_SG.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_SG.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_TT.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_TT.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_ZA.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_ZA.dic exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_ZW.aff exists in filesystem (owned by hunspell-en)
hunspell-en_GB: /usr/share/myspell/dicts/en_ZW.dic exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/hunspell/en_PH.aff exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/hunspell/en_PH.dic exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/hunspell/en_US.aff exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/hunspell/en_US.dic exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/myspell/dicts/en_PH.aff exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/myspell/dicts/en_PH.dic exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/myspell/dicts/en_US.aff exists in filesystem (owned by hunspell-en)
hunspell-en_US: /usr/share/myspell/dicts/en_US.dic exists in filesystem (owned by hunspell-en)
Errors occurred, no packages were upgraded.




Steps to reproduce: pacman -Syu

Is this a case of --overide?
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 15 August 2018, 17:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  2018.04.16-5
Comment by Doug Newgard (Scimmia) - Monday, 13 August 2018, 05:18 GMT
  • Field changed: Summary ([hunspell-en] file conflicts with hunspell-en_{AU,CA,GB,US} → [hunspell-en_{AU,CA,GB,US}] file conflicts with hunspell-en)
I would say the individual packages should conflict with hunspell-en so that pacman offers to remove the defunct package.

Edit: most definitely NOT a case for --overwrite, assuming that's what you meant since there is no --override.
Comment by jason ryan (jasonwryan) - Monday, 13 August 2018, 17:35 GMT
  • Field changed: Percent Complete (100% → 0%)
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: hunspell-en_AU and hunspell-en_CA are in conflict
Comment by Andreas Radke (AndyRTR) - Wednesday, 15 August 2018, 16:07 GMT
Jan, should we remove the provides and add replaces to each package?
Comment by Jan Steffens (heftig) - Wednesday, 15 August 2018, 16:14 GMT
Yes, IIRC that's what I originally suggested (only replaces and conflicts)

Loading...