Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59604 - [python-pip]

Attached to Project: Arch Linux
Opened by Doron Behar (doronbehar) - Friday, 10 August 2018, 13:00 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 10 August 2018, 14:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I get this error when running pip:

```
Traceback (most recent call last):
File "/usr/bin/pip", line 11, in <module>
load_entry_point('pip==18.0', 'console_scripts', 'pip')()
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 476, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2700, in load_entry_point
return ep.load()
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2318, in load
return self.resolve()
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2324, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python3.7/site-packages/pip/_internal/__init__.py", line 42, in <module>
from pip._internal import cmdoptions
File "/usr/lib/python3.7/site-packages/pip/_internal/cmdoptions.py", line 16, in <module>
from pip._internal.index import (
File "/usr/lib/python3.7/site-packages/pip/_internal/index.py", line 24, in <module>
from pip._internal.download import HAS_TLS, is_url, path_to_url, url_to_path
File "/usr/lib/python3.7/site-packages/pip/_internal/download.py", line 47, in <module>
from pip._internal.utils.ui import DownloadProgressProvider
File "/usr/lib/python3.7/site-packages/pip/_internal/utils/ui.py", line 11, in <module>
from pip._vendor.progress.bar import (
ModuleNotFoundError: No module named 'pip._vendor.progress'
```

I've read https://bbs.archlinux.org/viewtopic.php?id=237451 and https://bugs.archlinux.org/task/40713 which had some suggested solutions but nothing worked. For example, just for clarification: `pacman -Qlq python-pip | grep 3.6` prints nothing.

I've checked that my system is fully updated.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 10 August 2018, 14:42 GMT
Reason for closing:  Not a bug
Additional comments about closing:  pip works fine, your system is broken. Use the support forums to get help fixing your system, rather than the bugtracker to report a bug in our distribution.

Loading...