Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59589 - extra/qt5-base is over encompassing

Attached to Project: Arch Linux
Opened by Milk Brewster (milkmiruku) - Thursday, 09 August 2018, 13:10 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 09 August 2018, 21:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

* https://www.archlinux.org/packages/community/x86_64/quassel-core

Essentially an advanced IRC bouncer, has runtime depends for;

* https://www.archlinux.org/packages/extra/x86_64/qca-qt5
* https://www.archlinux.org/packages/extra/x86_64/qt5-script

(links against libqca-qt5.so and libQt5Script.so)

In other distros (Ubuntu/Debian based) this isn't a problem, as there qtcore and qtnetwork are their own packages.

But in the Arch packaging situation, this is not the case, instead they are bundled into qt5-base, which qca-qt5 and qt5-script depend on

* https://www.archlinux.org/packages/extra/x86_64/qt5-base

and qt5-base in turn has depends for many things including libcups, libglvnd, mesa, wayland, etc.


* https://gist.github.com/milkmiruku/a18e5a1d8afb0d970b7b23aa3f1a0add - pactree for quassel-core

I.e., installation on a server pulls down many unneeded graphics and other packages, making an install take up roughly an order of magnitude more space.


If a feature of the Qt framework is that some aspects of it are to be used in an application on a headless server, then I would say the current uncompartmentalised Arch approach to Qt packaging that doesn't respect is therefore buggy.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 09 August 2018, 21:33 GMT
Reason for closing:  Not a bug
Additional comments about closing:  That's how upstream distributes it. Not packaging things the way Debian does is not a bug
Comment by Milk Brewster (milkmiruku) - Thursday, 09 August 2018, 13:17 GMT
missed words, should have read; "...that doesn't respect this feature is therefore..."

edit, post closure:

elibrokeit> milkii: hmm, linked libs: https://paste.xinu.at/YFkkoE9/
elibrokeit> preliminarily speaking, it seems like it could be reasonable to split qt5-core/qt5-gui and this would remove both gl and libcups...
elibrokeit> though libcups is 7MB, extremely trivial. It's the reason we split cups/libcups

edit2: pactree output now at https://gist.github.com/mxmilkb/a18e5a1d8afb0d970b7b23aa3f1a0add

Loading...