Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59586 - [thunderbird] 60.0 comes without langage packages

Attached to Project: Arch Linux
Opened by Didier (dcro95) - Thursday, 09 August 2018, 09:37 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Friday, 10 August 2018, 12:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
I did a fresh installation and installation package thunderbird. I do not have the capabity to change langage from english to others.

The langage packs available in depot are not compatible with the new version 60.0

On https://www.thunderbird.net thunderbird with several langages is available.


Additional info:
* package version(s) : thunderbird 60.0-2
* config and/or log files etc.



This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Friday, 10 August 2018, 12:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  thunderbird 60.0-3
Comment by Robert (rowo) - Thursday, 09 August 2018, 13:48 GMT
The german language pack is not compatible with thunderbird versions 60+.
Comment by Andrea Amorosi (AndreaA) - Thursday, 09 August 2018, 18:52 GMT
The same happens to me with the italkian package which is still 52.9.1-1
Comment by A. Bosch (progandy) - Thursday, 09 August 2018, 21:13 GMT
I found language packs here:
https://releases.mozilla.org/pub/thunderbird/releases/60.0/linux-x86_64/xpi/

The thunderbird package itself has to be modified like firefox as well:

// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");

For now, I added this preference manually in about:config (Settings -> Advanced -> Button Config Editor)

By the way, the lightning language is still missing.
Comment by Patrick Legeron (patricklegeron) - Friday, 10 August 2018, 09:09 GMT
thunderbird-i18n-fr 60.0-2 don't work.
TB stay in english language
Comment by Alois Nespor (anespor) - Friday, 10 August 2018, 09:17 GMT
thunderbird-i18n-cs 60.0-2 don't work too. TB stay in english language
Comment by Chih-Hsuan Yen (yan12125) - Friday, 10 August 2018, 09:27 GMT
Well, thunderbird-i18n-zh-tw 60.0-2 works. I installed https://releases.mozilla.org/pub/thunderbird/releases/60.0/linux-i686/xpi/zh-TW.xpi manually yesterday, though. Of course I removed the manually installed one before installing the Arch Linux language package.
Comment by A. Bosch (progandy) - Friday, 10 August 2018, 09:31 GMT
See my last comment. You have to manually set "intl.locale.requested" to an empty string. The Thunderbird package is not doing it yet.
https://support.mozilla.org/en-US/kb/config-editor
Comment by Chih-Hsuan Yen (yan12125) - Friday, 10 August 2018, 09:37 GMT
FWIW, my "intl.locale.requested" is "zh-TW".
Comment by Andrea Amorosi (AndreaA) - Friday, 10 August 2018, 10:04 GMT
it works perfectly now.
"intl.locale.requested" is empty
Comment by Bartłomiej Piotrowski (Barthalion) - Friday, 10 August 2018, 11:55 GMT
Can someone confirm that 60.0-3 works as expected?
Comment by Alois Nespor (anespor) - Friday, 10 August 2018, 11:59 GMT
Yes, for me works again. (the lightning language is still missing)
Comment by Patrick Legeron (patricklegeron) - Friday, 10 August 2018, 12:07 GMT
Not work for me in french language
thunderbird 60.0-3 and language 60.0-2
intl.locale.requested : empty
Comment by Alois Nespor (anespor) - Friday, 10 August 2018, 12:11 GMT
clean installation (= new profile) of thunderbird-60.0-3 works https://i.imgur.com/zMyglf6.png
Comment by A. Bosch (progandy) - Friday, 10 August 2018, 12:34 GMT
Thunderbird 60.0-3 works here with the german language pack.

As for lightning I use this until upstream fixes it. https://gist.github.com/progandy/ce857358c4f3b8eb09887a085e4bea30
Comment by Bartłomiej Piotrowski (Barthalion) - Friday, 10 August 2018, 12:48 GMT
Feel free to report l10n for lightning separately but I'm unlikely to do anything about it.

Loading...