Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59585 - [thunderbird] Crashes on startup

Attached to Project: Arch Linux
Opened by Rokas Kupstys (rokups) - Thursday, 09 August 2018, 07:12 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Monday, 20 August 2018, 07:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Thunderbird crashes on startup (even with extensions disabled) because current version does not support migrating profiles from v52. According to comments on https://blog.mozilla.org/thunderbird/2018/08/whats-new-in-thunderbird-60/ upgrade will be ready for v60.1

Steps to reproduce:
1. Create profile with thunderbird 52
2. Upgrade to thunderbird 60
3. Start application
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Monday, 20 August 2018, 07:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  60.0-4
Comment by Eli Schwartz (eschwartz) - Thursday, 09 August 2018, 07:18 GMT
This worked fine for me, so I don't know what your problem is. Is there any terminal output? Is there a link to an upstream bug where this is discussed? Anything?
Comment by g angely (gangely) - Thursday, 09 August 2018, 08:50 GMT
about packge thunderbird-60.0-2-x86_64.pkg.tar.xz

Thunderbird crashed on two machines with the following message:
---
[calBackendLoader] Using Thunderbird's builtin libical backend
[1] 1512 segmentation fault (core dumped) thunderbird
---
Comment by Richard PALO (risto3) - Thursday, 09 August 2018, 09:06 GMT
I have similar issue (on Linux sarchx64 4.17.13-arch1-1-ARCH #1 SMP PREEMPT Mon Aug 6 23:06:31 UTC 2018 x86_64 GNU/Linux)
$ coredumpctl info -1
PID: 8518 (thunderbird)
UID: 1001 (richard)
GID: 100 (users)
Signal: 11 (SEGV)
Timestamp: Thu 2018-08-09 10:33:10 CEST (24min ago)
Command Line: /usr/lib/thunderbird/thunderbird
Executable: /usr/lib/thunderbird/thunderbird
Control Group: /user.slice/user-1001.slice/session-c2.scope
Unit: session-c2.scope
Slice: user-1001.slice
Session: c2
Owner UID: 1001 (richard)
Boot ID: 1ae32b7e663042578c8ab44f6d7d0143
Machine ID: 4ebaa767a0b041dc8b1012591595f293
Hostname: sarchx64
Storage: /var/lib/systemd/coredump/core.thunderbird.1001.1ae32b7e663042578c8ab44f6d7d0143.8518.1533803590000000.lz4
Message: Process 8518 (thunderbird) of user 1001 dumped core.

Stack trace of thread 8518:
#0 0x00007f1a65a9224f raise (libpthread.so.0)
#1 0x00007f1a5a2bd35e n/a (libxul.so)

quite useless tracebacks on stripped binaries.

Also, tbird was updated to 60.0 but without the i18n languages!

Finally, if I start 'thunderbird --ProfileManager', I can create a new profile
and start if selected. I'll see if it's possible to manually migrate,
if not then arch should revert until 60.1 as it is unacceptable to lose email capability in the meanwhile.
Comment by Richard PALO (risto3) - Thursday, 09 August 2018, 17:14 GMT
As far as my situation goes, I found that tb-60 was intolerant of a certain subfolder name under "Local Folders".

Luckily I was able to track it down and delete it, now tb starts. Get that!
Perhaps, rokups@ has a similar situation.

Only need -i18n-fr now, and ASAP please.
Comment by loqs (loqs) - Thursday, 09 August 2018, 17:26 GMT
@risto3 have you reproted your findings upstream?
Comment by Richard PALO (risto3) - Thursday, 09 August 2018, 20:22 GMT Comment by g angely (gangely) - Friday, 10 August 2018, 11:38 GMT
Same as @risto3 :
* tb60 was crashing, and I had in "Local Folders", files and sub-folders with accented characters (from fr locale)
* moved them to non-accented
* since, is tb60 ok
* @risto3: thanks for the tip
Comment by Eli Schwartz (eschwartz) - Monday, 13 August 2018, 19:08 GMT
Upstream fix has landed, we should backport the fix.
Comment by rettodsrednA ailemA (teirdes) - Tuesday, 14 August 2018, 19:36 GMT
I have a segmentation fault (core dumped) when I try to start Thunderbird 60.0-3. Downgrading back to 52.9 appears not to work since icu is updated too, causing libicui18n.so.61 no longer to be installable (by me).

Update: It works if I remove feeds with Swedish characters or accents in the names of them. This is not a world-breaking nuisance, but it's a nuisance.
Comment by Rokas Kupstys (rokups) - Wednesday, 15 August 2018, 06:53 GMT
I could not fix my profile even though i had no folders with special characters. Even newly rebuilt profile started failing soon after. If anyone is in same situation you can downgrade thunderbird by installing package from aur: https://aur.archlinux.org/packages/thunderbird-gtk2
Comment by Vinicius Massuchetto (vmassuchetto) - Friday, 17 August 2018, 10:44 GMT
Any version higher than 52 didn't work for me. Had to downgrade to 52.9.1-2 => `downgrader thunderbird`

Loading...