Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59555 - [python2-tornado] missing dependency which is required

Attached to Project: Community Packages
Opened by Terry Kerr (xnr) - Tuesday, 07 August 2018, 18:16 GMT
Last edited by Felix Yan (felixonmars) - Friday, 17 August 2018, 07:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

installing salt is not necessarily going to result in a functioning salt setup - it may be unable to run with the following exception:

```
from tornado.locks import Semaphore
File "/usr/lib/python2.7/site-packages/tornado/locks.py", line 18, in <module>
from concurrent.futures import CancelledError
ImportError: No module named concurrent.futures
```

fixing it's a simple affair - just install python2-futures. It would seem the best fix would be to add that as an explicit dependency of salt.


Steps to reproduce:
install fresh salt (I confirmed it personally in the base/archlinux:2018.08.01 docker container on 2018-08-07)
try to run salt


This task depends upon

Closed by  Felix Yan (felixonmars)
Friday, 17 August 2018, 07:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-tornado-5.1.0-2
Comment by Eli Schwartz (eschwartz) - Tuesday, 07 August 2018, 19:52 GMT
Hmm, it's always been listed by upstream as a dependency (since https://github.com/saltstack/salt/commit/ed8e068bf76574e20f49109bc378f2cb891d71bc when tornado was being added), but it's only being imported via tornado, and that only since https://github.com/tornadoweb/tornado/commit/606f0b5e90645fd8a1309043e839c5b0cf8abfad
Comment by Daniel Wendler (BMRMorph) - Monday, 13 August 2018, 08:33 GMT
maybe this isn't the fault of the salt dependencies.
on my systems it breaks after last system upgrade which includes python2-tornado (4.5.3-1 -> 5.1.0-1).
so i guess the optional dependency of python2-tornado on python2-futures shouldn't optional anymore?
Comment by Terry Kerr (xnr) - Monday, 13 August 2018, 16:27 GMT
Good call on that - if you check out http://www.tornadoweb.org/en/stable/releases/v5.0.0.html it specifies that on python2 futures is now a requirement so this should be opened as an issue on python2-tornado instead.

Loading...