Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59548 - [hplip] 3.18.7-1 breaks printing

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Tuesday, 07 August 2018, 07:19 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 16 August 2018, 18:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:
New hplip breaks all my printers with filter failed error on cups.

[Job 9839] Start rendering...
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Processing page 1...
D [06/Aug/2018:20:11:47 +0200] Discarding unused job-progress event...
D [06/Aug/2018:20:11:47 +0200] Discarding unused printer-state-changed event...
E [06/Aug/2018:20:11:47 +0200] [Job 9839] Unable to open raster stream - : Broken pipe
D [06/Aug/2018:20:11:47 +0200] Discarding unused job-progress event...
D [06/Aug/2018:20:11:47 +0200] Discarding unused printer-state-changed event...
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Error: /ioerror in --showpage--
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Operand stack:
D [06/Aug/2018:20:11:47 +0200] [Job 9839] true (/var/spool/cups/tmp/gs_Iy3oLk) --nostringval-- 1 true
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Execution stack:
D [06/Aug/2018:20:11:47 +0200] [Job 9839] %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 2015 2 3 %oparray_pop 2014 2 3 %oparray_pop 1998 2 3 %oparray_pop --nostringval-- --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- 1890 3 9 %oparray_pop --nostringval-- --nostringval--
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Dictionary stack:
D [06/Aug/2018:20:11:47 +0200] [Job 9839] --dict:1001/1684(ro)(G)-- --dict:1/20(G)-- --dict:83/200(L)-- --dict:83/200(L)-- --dict:133/256(ro)(G)-- --dict:305/450(ro)(G)-- --dict:33/64(L)-- --dict:6/9(L)-- --dict:8/20(L)--
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Current allocation mode is local
D [06/Aug/2018:20:11:47 +0200] [Job 9839] Last OS error: Broken pipe
D [06/Aug/2018:20:11:47 +0200] [Job 9839] GPL Ghostscript 9.23: Unrecoverable error, exit code 1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 16 August 2018, 18:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  initial issue has been fixed, libImageProcessor bug is tracked under FS#59681.
Comment by Tobias Powalowski (tpowa) - Tuesday, 07 August 2018, 08:25 GMT
https://bugs.launchpad.net/hplip/+bug/1784989
Perhaps it is the new CDS feature which causes here trouble.
Comment by Andreas (andmars) - Tuesday, 07 August 2018, 10:46 GMT
Same here and I'm the maintainer of hplip-plugins in AUR: Here's my /var/log/cups/error_log: https://pastebin.com/nZnUimBH

Comment by Juan Simón (j1simon) - Tuesday, 07 August 2018, 11:28 GMT
Same problem. This is a severe error.
Comment by Juan Simón (j1simon) - Tuesday, 07 August 2018, 11:45 GMT
If I execute `hp-doctor`:
```
HP Linux Imaging and Printing System (ver. 3.18.7)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.18.7)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/Traceback (most recent call last):
File "/usr/share/hplip/base/utils.py", line 266, in walkFiles
names = os.listdir(root)
FileNotFoundError: [Errno 2] No such file or directory: '/etc/PolicyKit'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/share/hplip/base/utils.py", line 268, in walkFiles
raise StopIteration
StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File "/usr/bin/hp-doctor", line 276, in <module>
dep.core.init()
File "/usr/share/hplip/installer/core_install.py", line 500, in init
self.check_dependencies(callback)
File "/usr/share/hplip/installer/core_install.py", line 593, in check_dependencies
self.have_dependencies[d] = self.dependencies[d][3]()
File "/usr/share/hplip/installer/core_install.py", line 1164, in check_policykit
if check_file('PolicyKit.conf', "/etc/PolicyKit") and check_file('org.gnome.PolicyKit.AuthorizationManager.service', "/usr/share/dbus-1/services"):
File "/usr/share/hplip/installer/dcheck.py", line 108, in check_file
for w in utils.walkFiles(dir, recurse=True, abs_paths=True, return_folders=False, pattern=f):
RuntimeError: generator raised StopIteration
```

```
$ hp-check
hp-check
Saving output in log file: /home/juan/hp-check.log

HP Linux Imaging and Printing System (ver. 3.18.7)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the
proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
OK
MISSING - Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version

/Traceback (most recent call last):
File "/usr/share/hplip/base/utils.py", line 266, in walkFiles
names = os.listdir(root)
FileNotFoundError: [Errno 2] No such file or directory: '/etc/PolicyKit'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/share/hplip/base/utils.py", line 268, in walkFiles
raise StopIteration
StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File "/usr/bin/hp-check", line 861, in <module>
dep.core.init()
File "/usr/share/hplip/installer/core_install.py", line 500, in init
self.check_dependencies(callback)
File "/usr/share/hplip/installer/core_install.py", line 593, in check_dependencies
self.have_dependencies[d] = self.dependencies[d][3]()
File "/usr/share/hplip/installer/core_install.py", line 1164, in check_policykit
if check_file('PolicyKit.conf', "/etc/PolicyKit") and check_file('org.gnome.PolicyKit.AuthorizationManager.service', "/usr/share/dbus-1/services"):
File "/usr/share/hplip/installer/dcheck.py", line 108, in check_file
for w in utils.walkFiles(dir, recurse=True, abs_paths=True, return_folders=False, pattern=f):
RuntimeError: generator raised StopIteration
```


```
Comment by loqs (loqs) - Tuesday, 07 August 2018, 13:22 GMT
When building the package in a clean chroot I am seeing this during package

make install-data-hook
make[2]: Entering directory '/build/hplip/src/hplip-3.18.7'
if [ \( "x86_64" = "x86_64" -a -d "/usr/lib/" \) ]; then \
cp prnt/hpcups/libImageProcessor-x86_64.so /usr/lib/ ; \
chmod 775 /usr/lib/libImageProcessor-x86_64.so ; \
ln -sf /usr/lib/libImageProcessor-x86_64.so /usr/lib/libImageProcessor.so ; \
fi; \
if [ \( \( "x86_64" = "i686" -o "x86_64" = "i386" \) -a -d "/usr/lib/" \) ]; then \
cp prnt/hpcups/libImageProcessor-x86_32.so /usr/lib/ ; \
chmod 775 /usr/lib/libImageProcessor-x86_32.so ; \
ln -sf /usr/lib/libImageProcessor-x86_32.so /usr/lib/libImageProcessor.so ; \
fi
cp: cannot create regular file '/usr/lib/libImageProcessor-x86_64.so': Permission denied
chmod: cannot access '/usr/lib/libImageProcessor-x86_64.so': No such file or directory
ln: failed to create symbolic link '/usr/lib/libImageProcessor.so': Permission denied
Comment by loqs (loqs) - Tuesday, 07 August 2018, 13:56 GMT
test patch that fixes up libImageProcessor install to see if it is related.
Comment by loqs (loqs) - Tuesday, 07 August 2018, 15:49 GMT
Also apply $(DESTDIR) to chmod
Comment by loqs (loqs) - Tuesday, 07 August 2018, 16:18 GMT
The python issues due to PEP-0479 which is the default with python 3.7 should probably be split into a separate bug.
Comment by Juan Simón (j1simon) - Wednesday, 08 August 2018, 10:51 GMT
Any workaround while this is still unresolved?
Comment by Kristijan Novoselic (knovoselic) - Wednesday, 08 August 2018, 11:00 GMT
j1simon Try downgrading to "hplip-3.18.6-2-x86_64.pkg.tar.xz" (https://archive.archlinux.org/packages/h/hplip/hplip-3.18.6-2-x86_64.pkg.tar.xz), it works for me.
Comment by Juan Simón (j1simon) - Wednesday, 08 August 2018, 11:23 GMT
Yes, thanks. That version works for me too.
Comment by A. Bosch (progandy) - Wednesday, 08 August 2018, 14:39 GMT
The missing libImageProcessor is most likely the cause, since the hpcups filter used in the hp ppd files links against it. At the moment I can't test it, though.

This is without the patch:

$ ldd /usr/lib/cups/filter/hpcups
linux-vdso.so.1 (0x00007fffcfbb6000)
libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007fbaf6523000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fbaf651e000)
libImageProcessor.so => not found
...
$ /usr/lib/cups/filter/hpcups
/usr/lib/cups/filter/hpcups: error while loading shared libraries: libImageProcessor.so: cannot open shared object file: No such file or directory
Comment by Andreas Radke (AndyRTR) - Wednesday, 08 August 2018, 18:00 GMT
3.18.7-2 adds missing library.
Comment by Robert (rowo) - Wednesday, 08 August 2018, 18:12 GMT
Same problem here. After downgrading everything is ok:

pacman -U https://archive.archlinux.org/packages/h/hplip/hplip-3.18.6-2-x86_64.pkg.tar.xz
Comment by loqs (loqs) - Wednesday, 08 August 2018, 19:17 GMT
@rowo 3.18.7-2 or you only used 3.18.7-1 ?

@AndyRTR https://bbs.archlinux.org/viewtopic.php?pid=1801189#p1801189 seems to be the fix for python 3.7 with hplip
Perhaps the license field should be updated to license=('GPL' 'MIT' 'BSD' 'custom' 'unknown')
From COPYING
MIT applies to
prnt/backend
io/hpmud
scan/sane
BSD applies to
prnt/hpijs
custom for IJG , unknown for libImageProcessor.so
IJG prnt/hpijs/jccolor.c prnt/hpijs/README_LIBJPG
base/exif.py custom
fedora also include ISC https://src.fedoraproject.org/rpms/hplip/blob/master/f/hplip.spec#_11 but I could not find a file with a matching license
Comment by Andreas Radke (AndyRTR) - Wednesday, 08 August 2018, 19:59 GMT
Please test 3.18.7-3. Thanks loqs!
Comment by Robert (rowo) - Wednesday, 08 August 2018, 20:17 GMT
@loqs I used 3.18.7-1
Comment by Robert (rowo) - Wednesday, 08 August 2018, 20:34 GMT
I just tested 3.18.7-3, all seems fine!
Comment by Robert (rowo) - Wednesday, 08 August 2018, 20:56 GMT
diff hp-doctor-HPLIP-3.18.7-3.txt hp-doctor-HPLIP-3.18.7-1.txt
134,137d133
< [installation]
< date_time = 08/08/18 22:49:51
< version = 3.18.7
<
139c135
< device_uri = "hp:/usb/DeskJet_940C?serial=CN15U6C0J7BH"
---
> device_uri = hp:/usb/DeskJet_940C?serial=CN15U6C0J7BH
161a158,161
> [installation]
> date_time = 08/08/18 19:01:27
> version = 3.18.7
>
250c250
< Printer status: Drucker DESKJET-940C ist im Leerlauf. Aktiviert seit Mi 08 Aug 2018 22:32:49 CEST
---
> Printer status: Drucker DESKJET-940C ist im Leerlauf. Aktiviert seit Do 09 Nov 2017 19:44:03 CET
267c267
< USB HP-Photosmart-B110-series Required - - OK Node:'/dev/bus/usb/001/003' Perm:' root lp rw- rw- rw- rw- r--'
---
> USB HP-Photosmart-B110-series Required - - OK Node:'/dev/bus/usb/001/005' Perm:' root lp rw- rw- rw- rw- r--'
Comment by Andreas (andmars) - Thursday, 09 August 2018, 13:07 GMT
With 3.18.7-3 I still get the "Filter failed" bug and the printer refuses to print (HP_LaserJet_Professional_P1102)
Comment by Nicholas Wilson (wilsonnck) - Thursday, 09 August 2018, 15:42 GMT
3.18.7-3 works for me. HP_OfficeJet_Pro_8710
Comment by Andreas Radke (AndyRTR) - Thursday, 09 August 2018, 17:48 GMT
@andmars - does this happen with your AUR pkg? It might need a rebuild to pick up added library. At least this should be a different issue and the initial two bugs seem fixed. Going to close this one report.
Comment by Dimos Dimoulis (dimosd) - Thursday, 09 August 2018, 22:32 GMT
3.18.7-3 doesn't work for me either (I am using it with hplip-plugin from AUR, latest version). I am seeing "Process 1386 (hpcups) of user 209 dumped core." in the system log. Model HP LaserJet P1005.
Comment by Cyrus Taraporvala (NZCyrus) - Friday, 10 August 2018, 05:26 GMT
Can confirm that the latest hplip 3.18.7-3 throws a 'Filter failed' error after upgrading. My printer is an Officejet 4650. Had to downgrade to resolve.
Comment by Juan Simón (j1simon) - Friday, 10 August 2018, 09:50 GMT
3.18.7-3 works for me in a HP Envy 4526. I haven't installed hplip-plugin.
Comment by Genues (Genues) - Friday, 10 August 2018, 10:00 GMT
3.18.7-3 not works for me at HP 1018
Comment by frederick_metzengerstein (metzengerstein) - Friday, 10 August 2018, 12:21 GMT
3.18.7.3 works for me with HP Deskjet 3550
Comment by Tobias Powalowski (tpowa) - Monday, 13 August 2018, 14:30 GMT
3.18.7-3 does not work for my printers.
Comment by Andreas Radke (AndyRTR) - Monday, 13 August 2018, 15:17 GMT
Everybody with broken printing please check your log files. If no error pops up there please check your used ppd files if it contains some perl calls or other magic and if you have an alternative ppd file you can choose: http://openprinting.org/printers/manufacturer/HP

(For my Samsung PLX printer I had to switch to some generic ppd lately due to perl changes.)
Comment by Dimos Dimoulis (dimosd) - Monday, 13 August 2018, 16:04 GMT
Can we stay with the working version 3.18.6 for the foreseeable future, until this is fixed upstream, by recompiling the package?
Comment by loqs (loqs) - Monday, 13 August 2018, 16:09 GMT
@dimosd have you reported the issue upstream?
Comment by Dimos Dimoulis (dimosd) - Monday, 13 August 2018, 16:30 GMT
@loqs Probably some incompatibility with the latest version of some dependency.
Comment by loqs (loqs) - Monday, 13 August 2018, 16:57 GMT
@dimosd https://bugs.launchpad.net/hplip/+bug/1785230 indicates upstream is not aware of at least https://bbs.archlinux.org/viewtopic.php?pid=1801801#p1801801
Is that your issue or is yours a ppd issue or another issue? You do not seem to have posted anything indicating the cause of the issue on your system.
Comment by Dimos Dimoulis (dimosd) - Monday, 13 August 2018, 18:03 GMT
@loqs I think it's the same issue as the one in your second link.
Comment by nicolo (nicolo) - Monday, 13 August 2018, 18:05 GMT
For me as well 3.18.7-3 still gives errors:
E [13/Aug/2018:09:31:29 -0400] [Job 92] Job stopped due to filter errors; please consult the error_log file for details.
D [13/Aug/2018:09:31:29 -0400] [Job 92] 3 filters for job:
D [13/Aug/2018:09:31:29 -0400] [Job 92] pdftopdf (application/pdf to application/vnd.cups-pdf, cost 66)
D [13/Aug/2018:09:31:29 -0400] [Job 92] gstoraster (application/vnd.cups-pdf to application/vnd.cups-raster, cost 99)
D [13/Aug/2018:09:31:29 -0400] [Job 92] hpcups (application/vnd.cups-raster to printer/HP-LaserJet-p4015dn, cost 0)
D [13/Aug/2018:09:31:29 -0400] [Job 92] prnt/hpcups/HPCupsFilter.cpp 644: DEBUG: SHIVA inside the while loopprnt/hpcups/HPCupsFilter.cpp 648: DEBUG: imageProcessorStartPage failed result = 2
Comment by loqs (loqs) - Monday, 13 August 2018, 19:19 GMT
Test patch to remove the use of imageProcessor. Does rebuilding with this patch resolve the issue for those with debug output like nicolo's?
Comment by Tobias Powalowski (tpowa) - Tuesday, 14 August 2018, 06:39 GMT
Using loqs patch fixes printing for me.
Comment by icoz (icoz) - Tuesday, 14 August 2018, 18:09 GMT
Same. Version 3.18.7-3 gives errors:
D [14/Aug/2018:20:55:56 +0300] [Job 138] Start rendering...
D [14/Aug/2018:20:55:56 +0300] [Job 138] Set job-printer-state-message to "Start rendering...", current level=INFO
D [14/Aug/2018:20:55:56 +0300] [Job 138] Processing page 1...
D [14/Aug/2018:20:55:56 +0300] [Job 138] Set job-printer-state-message to "Processing page 1...", current level=INFO
D [14/Aug/2018:20:55:56 +0300] [Job 138] prnt/hpcups/HPCupsFilter.cpp 644: DEBUG: SHIVA inside the while loopprnt/hpcups/HPCupsFilter.cpp 648: DEBUG: imageProcessorStartPage failed result = 2
D [14/Aug/2018:20:55:56 +0300] [Job 138] STATE: +connecting-to-device
D [14/Aug/2018:20:55:56 +0300] [Job 138] PAGE: 1 1\r
D [14/Aug/2018:20:55:56 +0300] [Job 138] STATE: -connecting-to-device
D [14/Aug/2018:20:55:56 +0300] [Job 138] STATE: -media-empty-error,media-jam-error,hplip.plugin-error,cover-open-error,toner-empty-error,other
D [14/Aug/2018:20:55:56 +0300] [Job 138] PID 27268 (/usr/lib/cups/filter/hpcups) crashed on signal 11.

Revert to 3.18.6 solved problem...
Comment by loqs (loqs) - Tuesday, 14 August 2018, 19:24 GMT

Loading...