Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59535 - [python-ipykernel] [jupyter] ipython kernels do not start

Attached to Project: Community Packages
Opened by Fil T (fijit) - Monday, 06 August 2018, 13:10 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 10 August 2018, 17:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
Launching "jupyter console" or starting a notebook kernel (either python2 or python3) fail. Please see attached logs.
Running ipython or ipython2 directly works as expected.

Additional info:
* package version(s)
jupyter_console 5.2.0-2
jupyter-notebook 5.3.0-4
ipython 6.5.0-2
ipython2 5.8.0-1
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 10 August 2018, 17:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-ipykernel 4.8.2-1
Comment by Fil T (fijit) - Monday, 06 August 2018, 18:10 GMT
Sorry, jupyter et al are in [community] so project should be "Community packages" instead.
Comment by Taras Shpot (mrshpot) - Monday, 06 August 2018, 20:39 GMT
The cause seems to be python-tornado >= 5:
https://github.com/jupyter/notebook/issues/3397
Comment by bob (getzze) - Thursday, 09 August 2018, 16:54 GMT
jupyter is working again by updating python-ipykernel to the last version 4.8.2.
The update to 4.8.2 is easy, just updating the pkgver, although I didn't test with python2.
Can you please update the package in the official repo?
Comment by Simon (Giggi) - Friday, 10 August 2018, 09:45 GMT
I've updated python-ipykernel to the version 4.8.2
as a result spyder3 and Jupyter are working.

So it seems that this update fix the bug.

Loading...