Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59469 - [git] zsh completion throws errors on tab completion

Attached to Project: Arch Linux
Opened by Chet Gurevitch (chetgurevitch) - Saturday, 28 July 2018, 02:20 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 03 August 2018, 15:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Completions for certain commands result in errors (ex. git fetch: __git_remote_repositories:4: command not found: _ssh_hosts). This can be fixed by moving /usr/share/git/completion/git-completion.zsh to /usr/share/zsh/site-functions/_git. Credit [1]

Steps to reproduce:

Try tab completing 'git fetch repositorynamehe'

1: https://stackoverflow.com/questions/28028740/git-tab-completion-in-zsh-throwing-errors#28035917
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 03 August 2018, 15:03 GMT
Reason for closing:  Works for me
Comment by Eli Schwartz (eschwartz) - Tuesday, 31 July 2018, 17:23 GMT
$ pacman -Qo /usr/share/zsh/functions/Completion/Unix/_git
/usr/share/zsh/functions/Completion/Unix/_git is owned by zsh 5.5.1-2

zsh completions work entirely fine for me with no problems whatsoever, so I'm unsure why you claim it throws errors on tab-completion. Moreover, the discussion you linked has absolutely nothing to do with missing _ssh_hosts

Loading...