Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59466 - [syslog-ng] Please depend on 'libsystemd.so' rather than 'systemd'

Attached to Project: Arch Linux
Opened by Luke Shumaker (lukeshu) - Friday, 27 July 2018, 18:46 GMT
Last edited by Antonio Rojas (arojas) - Friday, 27 July 2018, 22:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

syslog-ng depends=(systemd) because it is compiled --enable-systemd, which enables socket activation via libsystemd, and enables the sdjournal module. This however, does not require systemd; it will fall back to opening the socket itself if systemd isn't running, and the sdjournal module can be disabled at runtime (it's actually disabled by default).

'syslog-ng' only really needs to depend on the libsystemd.so library, which it currently pulls in by depending on 'systemd', which in turn depends on 'libsystemd', which includes that library.

Users of derivatives of Arch (and users of AUR?) might like to install a different init system, and a different udev implementation. By editing mkinitcpio's depends=() to more precisely identify what it needs, it would make it so that downstream distros don't need to edit the PKGBUILD of syslog-ng.

As a final note, I would prefer the dependency to say 'libsystemd.so' rather than 'libsystemd' (which is both libsystemd.so and libudev.so); syslog-ng has no dependency on libudev.

This would be helpful to Parabola, and to AUR eudev users.

Additional info:
* package version(s): syslog-ng extra/3.15.1-3 & staging/3.15.1-4
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 27 July 2018, 22:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  in svn
Comment by Luke Shumaker (lukeshu) - Friday, 27 July 2018, 18:49 GMT
Oops: s/mkinitcpio/syslog-ng/ in the middle there; I copied that paragraph from FS#59364.
Comment by Eli Schwartz (eschwartz) - Friday, 27 July 2018, 18:58 GMT
What problem is caused by depending on libsystemd which happens to provide libudev.so? Who said syslog-ng depends on libudev?

Whether to choose libsystemd or libsystemd.so is entirely a matter of whether one wishes to depend on a package or a soname, where the latter is in general discouraged as it can make rebuilding packages outside of a clean chroot, burdensome, while usually providing no real benefit for a distro that does not support partial updates.

Loading...