Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59452 - [thunar] Dismount notification no longer shown

Attached to Project: Arch Linux
Opened by Clemmitt Sigler (cmsigler) - Wednesday, 25 July 2018, 20:57 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 29 May 2020, 03:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When using Xfce and dismounting removable media by using the icon's right-click popup menu, the expected dismount notification is no longer shown. This has always worked until recently (I'm not sure of the date when it started to fail). I assumed it was due to a recent Xfce package upgrade.

I tried downgrading packages I suspected could be involved. It is only when I downgraded thunar to 1.6.15-1 *and* xfdesktop to 4.12.4-1 at the same time that these dismount notifications were recovered and functioned as expected.

Additional info:
thunar 1.8.1-1 and 1.8.1.11.gf5147445-1
xfdesktop 4.12.4-2

With these packages installed the dismount notifications are missing.

Steps to reproduce:
1.) Install xfce4 desktop with current up-to-date packages (namely, thunar-1.8.1.11.gf5147445-1 and xfdesktop-4.12.4-2)
2.) Configure desktop icons so all Default Icons are on/checked
3.) Configure notifications so all Applications listed are turned ON
4.) Insert removable media
5.) Icon for removable media appears on desktop
6.) Right-click and choose Mount Volume, then wait for volume to be mounted
7.) Right-click and choose Unmount Volume
8.) No dismount notification is displayed as a popup

Expected behavior is for an "Unmount Finished" notification popup to be displayed.

HTH.

Clemmitt Sigler
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 29 May 2020, 03:11 GMT
Reason for closing:  Works for me
Additional comments about closing:  I don't remember if I was able to repro back when this bug was filed, but "writing to disk" notifications have been working fine for me for a long time.
Comment by Doug Newgard (Scimmia) - Wednesday, 01 August 2018, 15:45 GMT
Do any notifications work?
Comment by Clemmitt Sigler (cmsigler) - Wednesday, 01 August 2018, 15:57 GMT
Hey,

Power Manager notifications work fine. So far it just seems to be Unmount Volume (and Eject Volume) that don't pop up.

I'm not sure what other notifications I can test. Though come to think of it, I recently got a Facebook notification from Google Chrome unstable (which I promptly disabled; settings -> content settings -> notifications). So that worked as well.

If there's anything else I can test please let me know. I'd love to get this fixed but have zero experience with the Xfce codebase.

Clemmitt

Loading...