Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59435 - [curl] 7.61.0-1 rendering strange ANSI control sequences

Attached to Project: Arch Linux
Opened by brent saner (sanerb) - Tuesday, 24 July 2018, 17:21 GMT
Last edited by Christian Hesse (eworm) - Tuesday, 24 July 2018, 19:27 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When using curl to get response headers (this is the only behaviour I've noticed it occur in, as that's what I use curl the most for) - but NOT to fetch actual page content - I'm noticing strange bold and underlined characters, necessitating a "reset" command to restore the normal shell prompt. This does not seem to occur when I am capturing the output, either with a shell redirect, pipe, etc.

I have attached a screenshot of this behaviour, since I can't seem to capture the actual ANSI with simple shell mechanisms (I suspect curl is responsible for determining if it's being piped or not?).

This *seems* to have started with the latest update to curl I've performed (on 2018-07-13 18:53) to 7.16.0-1, but I can't be 100% certain on that.

Additional info:
* curl 7.16.0-1

I am using gnome-terminal as my terminal emulator. However, this occurs even in xterm (and even on a TTY, though obviously the rendering looks a bit different).

[bts@cylon ~]$ echo $SHELL
/bin/bash

Bash environment:
LC_ALL=
LC_MEASUREMENT=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
ANDROID_HOME=/opt/android-sdk
XDG_MENU_PREFIX=gnome-
LANG=en_US.UTF-8
GDM_LANG=en_US.UTF-8
DISPLAY=:1
HISTTIMEFORMAT=%F %T
EDITOR=vim
COLORTERM=truecolor
USERNAME=bts
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
XDG_VTNR=2
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
HG=/usr/bin/hg
LC_NAME=en_US.UTF-8
XDG_SESSION_ID=c2
USER=bts
DESKTOP_SESSION=gnome
LC_COLLATE=en_US.UTF-8
GRADLE_HOME=/usr/share/java/gradle
GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/68d2b95d_3277_45dc_a4e2_e57f670de293
PWD=/home/bts
HOME=/home/bts
LC_CTYPE=en_US.UTF-8
XDG_SESSION_TYPE=x11
XDG_DATA_DIRS=/home/bts/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/
XDG_SESSION_DESKTOP=gnome
LC_ADDRESS=en_US.UTF-8
GJS_DEBUG_OUTPUT=stderr
LC_NUMERIC=en_US.UTF-8
MAIL=/var/spool/mail/bts
WINDOWPATH=2
TERM=xterm-256color
SHELL=/bin/bash
VTE_VERSION=5202
LC_MESSAGES=en_US.UTF-8
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
XDG_CURRENT_DESKTOP=GNOME
GNOME_TERMINAL_SERVICE=:1.84
XDG_SEAT=seat0
SHLVL=1
LC_TELEPHONE=en_US.UTF-8
GDMSESSION=gnome
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
LOGNAME=bts
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
XDG_RUNTIME_DIR=/run/user/1000
XAUTHORITY=/run/user/1000/gdm/Xauthority
PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/opt/android-sdk/platform-tools:/opt/android-sdk/tools:/opt/android-sdk/tools/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:~/bin:/sbin:/bin:/usr/sbin
LC_IDENTIFICATION=en_US.UTF-8
GJS_DEBUG_TOPICS=JS ERROR;JS LOG
SESSION_MANAGER=local/cylon:@/tmp/.ICE-unix/1539,unix/cylon:/tmp/.ICE-unix/1539
LC_TIME=en_US.UTF-8
OLDPWD=/tmp
_=/usr/bin/env

Steps to reproduce:

curl -sIL <ANY_URL>

e.g.:

curl -sIL https://g.rainwreck.com
This task depends upon

Closed by  Christian Hesse (eworm)
Tuesday, 24 July 2018, 19:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  curl-7.61.0-2
Comment by Dave Reisner (falconindy) - Tuesday, 24 July 2018, 17:35 GMT
Surely you mean curl 7.61.0 ... curl 7.16.0 is over a decade old.

I can't reproduce the "leakage", but I do see this as wrongly styled (only the header *name* should be bolded).
Comment by Eli Schwartz (eschwartz) - Tuesday, 24 July 2018, 17:38 GMT
Comment by brent saner (sanerb) - Tuesday, 24 July 2018, 18:07 GMT
whoops! correct, 7.61.0. terribly sorry!

Loading...