Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59392 - [quota-tools] error in package() due to missing header files

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 19 July 2018, 16:03 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 19 July 2018, 18:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

rm: cannot remove '/build/quota-tools/pkg/quota-tools/usr/include/rpcsvc/rquota.h': No such file or directory
rm: cannot remove '/build/quota-tools/pkg/quota-tools/usr/include/rpcsvc/rquota.x': No such file or directory

# remove conflicts with glibc
rm "${pkgdir}"/usr/include/rpcsvc/rquota.{h,x}

Seems commenting out this rm makes the package build.

This seems to be fixed upstream.

Additional info:
* package version(s): 4.04-1


Steps to reproduce:

asp export quota-tools
cd quota-tools
staging-x86_64-build

This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 19 July 2018, 18:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  quota-tools 4.04-2

Loading...