Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59350 - [consul] Installed example configuration violates consul normal works after restart

Attached to Project: Community Packages
Opened by Andrey Platonov (kowalski) - Monday, 16 July 2018, 08:42 GMT
Last edited by Thore Bödecker (foxxx0) - Friday, 14 September 2018, 13:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thore Bödecker (foxxx0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Example configuration "example.json" has installed after each package upgrade. This behavior leads to a violation of the normal work of already configured consul agent because after restarting it doesn't start properly.
I suggest renaming " example.json " in " config.json.example" during package installation.

Additional info:
* consul 1.0.6

Steps to reproduce:
1) Install consul, start it as agent and register some services in consul catalog
2) update consul to the newer version and restart it
This task depends upon

Closed by  Thore Bödecker (foxxx0)
Friday, 14 September 2018, 13:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed as of consul-1.2.3-1
Comment by Daniel Wendler (BMRMorph) - Wednesday, 12 September 2018, 15:33 GMT
It would be great if this could be fixed bevor 1.2.2-1 leaves "testing" as it breaks existing installations if someone restart consul with the example file in place.
Comment by Daniel Wendler (BMRMorph) - Thursday, 13 September 2018, 13:35 GMT
Maybe another minor one, please flag "/etc/default/consul" as an backup file as it gets also overwritten on upgrade (if someone use it).

Loading...