Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59291 - Error when starting QGIS: Couldn't load PyQGIS.

Attached to Project: Community Packages
Opened by Pedro Neves (paneves) - Tuesday, 10 July 2018, 11:25 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 10 July 2018, 13:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When startig QGIS 3.2.0-1 I get the following error:

Couldn't load PyQGIS.
Python support will be disabled.

traceback (most recent call last):
File "", line 1, in
File "/usr/lib/python3.6/site-packages/qgis/__init__.py", line 80, in
import qgis.gui
File "/usr/lib/python3.6/site-packages/qgis/gui/__init__.py", line 27, in
from qgis._gui import *
ValueError: PyCapsule_GetPointer called with incorrect name


Additional info:
* package version(s)
* config and/or log files etc.

Python version:
3.6.6 (default, Jun 27 2018, 13:11:40)
[GCC 8.1.1 20180531]

QGIS version:
3.2.0-Bonn 'Bonn', exported

Python path:
['/usr/share/qgis/python', '/home/xxxxxx/.local/share/QGIS/QGIS3/profiles/default/python', '/home/xxxxxx/.local/share/QGIS/QGIS3/profiles/default/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python36.zip', '/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload', '/usr/lib/python3.6/site-packages']



Steps to reproduce:

Start qgis. While QGIS is starting the error message is displayed. When I click "close", another message shows:

An error occurred during execution of following code:
qgis.utils.uninstallErrorHook()


Traceback (most recent call last):
File "", line 1, in
NameError: name 'qgis' is not defined

After I close this message window, QGIS starts...

I believe that this started after today's upgrade (from /var/log/pacman.log):

upgraded pyqt5-common (5.10.1-7 -> 5.11.2-1)
installed python-sip-pyqt5 (4.19.12-4)
upgraded python-pyqt5 (5.10.1-7 -> 5.11.2-1)
upgraded qscintilla-qt4 (2.10.4-1 -> 2.10.7-1)
upgraded python-qscintilla-qt4-common (2.10.4-1 -> 2.10.7-1)
upgraded qscintilla-qt5 (2.10.4-1 -> 2.10.7-1)
upgraded python-qscintilla-qt5-common (2.10.4-1 -> 2.10.7-1)
upgraded python-qscintilla-qt5 (2.10.4-1 -> 2.10.7-1)
upgraded python-sip (4.19.8-1 -> 4.19.12-4)
installed python2-sip-pyqt5 (4.19.12-4)
upgraded python2-pyqt5 (5.10.1-7 -> 5.11.2-1)
upgraded sip (4.19.8-1 -> 4.19.12-4)
upgraded python2-sip (4.19.8-1 -> 4.19.12-4)
upgraded python2-qscintilla-qt4 (2.10.4-1 -> 2.10.7-1)
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 10 July 2018, 13:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  qgis 3.2.0-2
Comment by Kim Lindgren (Froglich) - Tuesday, 10 July 2018, 12:57 GMT
I would suggest increasing the severity of this bug to at least high, since no Python support means that QGIS functionality becomes severely limited

Loading...