Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59273 - [java-environment-common] javah is a broken symlink

Attached to Project: Arch Linux
Opened by Christian Rebischke (Shibumi) - Sunday, 08 July 2018, 19:36 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 08 July 2018, 21:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello,
I am working on a new version of facter. Facter needs javah for the build process.
But somehow the symlink of javah seems to be broken.

Steps to reproduce:

create a fresh arch linux systemd-nspawn containter with pacstrap, install java-environment-common in it and check /usr/bin/javah.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 08 July 2018, 21:00 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 08 July 2018, 20:59 GMT
Of course it's broken until you actually install a java environment.
javah is dead and gone with java 10, so you'd need an earlier version.

Loading...