Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59270 - [dotnet-sdk] .NET Core SDK uses static gid=100 for users

Attached to Project: Community Packages
Opened by Veli-Jussi Raitila (vjraitila) - Sunday, 08 July 2018, 17:37 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 20 August 2018, 19:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The .NET Core SDK package seems to set a static gid of 100 for all installed files. To my understanding Arch Linux has since moved away from predictable group identifiers. Therefore, none of the installed files are correctly owned by the 'users' group. In fact, no group with gid 100 exists on my system.

Additional info:
* dotnet-sdk 2.1.1+301-1

STEPS TO REPRODUCE

1. Run 'pacman -S dotnet-sdk' on a system where 'users' group has gid <> 100
2. Examine files/directory ownership under /opt/dotnet

EXPECTED RESULTS
- Files are correctly owned by the 'users' group

ACTUAL RESULTS
- Files are owned by gid 100
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 20 August 2018, 19:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  dotnet-core 2.1.2+302-1
Comment by Veli-Jussi Raitila (vjraitila) - Sunday, 08 July 2018, 18:39 GMT
Actually, now that I think about it, the files should not definitely be owned by the user performing the install at all - regardless of the group gid. Other distros I've used dotnet-sdk with have the ownership set to root:root as expected.
Comment by Veli-Jussi Raitila (vjraitila) - Monday, 09 July 2018, 06:51 GMT
On a Mac the ownership is set to root:wheel

Loading...