Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59269 - Bug in qt5-base affects Dolphin, maybe other packages.

Attached to Project: Arch Linux
Opened by Gabriel Felipe Huwe (DemonicSavage) - Sunday, 08 July 2018, 14:59 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 08 July 2018, 15:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
A known bug in Qt 5.11.1 affects the Dolphin file manager and maybe other Qt 5 applications.
In Dolphin's case, some settings, such as the visibility of the menubar and the toolbar do not persist after closing the application.
Apparently, this is caused by a commit, which could be reversed to fix the error, as seen in this OBS patch: https://build.opensuse.org/package/view_file/openSUSE:Factory/libqt5-qtbase/0001-Revert-QWidgetWindow-Immediately-forward-close-event.patch?expand=1

Additional info:
* package version(s)
qt5-base 5.11.1-1
dolphin 18.04.2-1

* config and/or log files etc.
Attached is my dolphinrc. It was modified on starting Dolphin. As an example of what was modified, the MenuBar=disabled line shouldn't be there.

Steps to reproduce:
Open Dolphin
Press Ctrl+M to toggle the menu bar
Close Dolphin
Start Dolphin again
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 08 July 2018, 15:10 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#59251 

Loading...