Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59262 - [systemd] gnome-shell cannot start after upgrading systemd and libsystemd to 239

Attached to Project: Arch Linux
Opened by Freddie Chopin (Freddie Chopin) - Saturday, 07 July 2018, 22:57 GMT
Last edited by Jan Steffens (heftig) - Thursday, 27 September 2018, 09:41 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan Steffens (heftig)
Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 38
Private No

Details

Description:
After upgrading systemd and libsystemd to 239.0-2 (from 238) gnome-shell crashes during boot process, right after "starting version 239" and info about root filesystem is printed. System appears to be stuck in the boot process, however it is possible to switch to another tty and use console.

Below is the relevant dump from journalctl:

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

lip 08 00:32:19 ... systemd-coredump[606]: Process 566 (gnome-shell) of user 120 dumped core.

Stack trace of thread 566:
#0 0x00007ff42d0287b5 meta_gpu_kms_new (libmutter-2.so.0)
#1 0x00007ff42d02a0dc n/a (libmutter-2.so.0)
#2 0x00007ff42f049121 g_initable_new_valist (libgio-2.0.so.0)
#3 0x00007ff42f0491da g_initable_new (libgio-2.0.so.0)
#4 0x00007ff42cf7a62a n/a (libmutter-2.so.0)
#5 0x00007ff42cf7b288 meta_init_backend (libmutter-2.so.0)
#6 0x00007ff42cfc4bf8 meta_init (libmutter-2.so.0)
#7 0x0000559b326f1cca n/a (gnome-shell)
#8 0x00007ff42f7f206b __libc_start_main (libc.so.6)
#9 0x0000559b326f213a n/a (gnome-shell)

Stack trace of thread 569:
#0 0x00007ff42f8bcea9 __poll (libc.so.6)
#1 0x00007ff42eaca523 n/a (libglib-2.0.so.0)
#2 0x00007ff42eaca63e g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007ff42eaca692 n/a (libglib-2.0.so.0)
#4 0x00007ff42eaf2a2a n/a (libglib-2.0.so.0)
#5 0x00007ff42fb92075 start_thread (libpthread.so.0)
#6 0x00007ff42f8c753f __clone (libc.so.6)

Stack trace of thread 571:
#0 0x00007ff42f8bcea9 __poll (libc.so.6)
#1 0x00007ff42eaca523 n/a (libglib-2.0.so.0)
#2 0x00007ff42eaca63e g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007ff4135f8f4e n/a (libdconfsettings.so)
#4 0x00007ff42eaf2a2a n/a (libglib-2.0.so.0)
#5 0x00007ff42fb92075 start_thread (libpthread.so.0)
#6 0x00007ff42f8c753f __clone (libc.so.6)

Stack trace of thread 575:
#0 0x00007ff42f8c20f9 syscall (libc.so.6)
#1 0x00007ff42eb1152d g_cond_wait_until (libglib-2.0.so.0)
#2 0x00007ff42ea9c903 n/a (libglib-2.0.so.0)
#3 0x00007ff42eaf3436 n/a (libglib-2.0.so.0)
#4 0x00007ff42eaf2a2a n/a (libglib-2.0.so.0)
#5 0x00007ff42fb92075 start_thread (libpthread.so.0)
#6 0x00007ff42f8c753f __clone (libc.so.6)

Stack trace of thread 570:
#0 0x00007ff42f8bcea9 __poll (libc.so.6)
#1 0x00007ff42eaca523 n/a (libglib-2.0.so.0)
#2 0x00007ff42eaca8e2 g_main_loop_run (libglib-2.0.so.0)
#3 0x00007ff42f0b9348 n/a (libgio-2.0.so.0)
#4 0x00007ff42eaf2a2a n/a (libglib-2.0.so.0)
#5 0x00007ff42fb92075 start_thread (libpthread.so.0)
#6 0x00007ff42f8c753f __clone (libc.so.6)

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

Downgrading to last installed versions of systemd and libsystemd (238.133-4) solved the issue right away and Gnome starts correctly. Please let me know what additional details I could provide.
This task depends upon

Closed by  Jan Steffens (heftig)
Thursday, 27 September 2018, 09:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  Possibly fixed by GDM, Mutter or Systemd updates.
Comment by loqs (loqs) - Saturday, 07 July 2018, 23:07 GMT Comment by John Sides (Ookami86) - Sunday, 08 July 2018, 07:37 GMT
I am experiencing the same issue. Since it looks like a GPU related issue(?) note that my GPU is from Nvidia, using their properietary driver. After downgrading systemd and libsystemd as described gdm is working again.
Comment by Freddie Chopin (Freddie Chopin) - Sunday, 08 July 2018, 08:18 GMT
I'm also on Nvidia. In my post in the thread linked above - https://bbs.archlinux.org/viewtopic.php?pid=1796289#p1796289 - I posted a hint which may actually be a solution for the problem. It's quite possible that the problem is in Wayland, enabled by default on Gnome now, yet known to not work with Nvidia cards.
Comment by Barakah AlRashedi (unixv) - Sunday, 08 July 2018, 08:56 GMT
I have same issue since booting process got stuck and freeze before GUI initialization.
after downgraded below packages the issue is solved:
downgraded libsystemd (239.0-2 -> 238.133-4)
downgraded systemd (239.0-2 -> 238.133-4)
downgraded systemd-sysvcompat (239.0-2 -> 238.133-4)


all others packages are upgraded to latest version:
gnome-shell (3.28.2-1)
gdm (3.28.2-1)
nvidia (396.24-14)
linux (4.17.4-1)
linux-headers (4.17.4-1)


GDM configuration: /etc/gdm/custom.conf
--------------------------------------------------------------------------
[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true
--------------------------------------------------------------------------
Comment by Luhrel (Luh) - Sunday, 08 July 2018, 09:15 GMT
Same problem here, thank you Freddie Chopin for the "disable wayland fix".
Comment by loqs (loqs) - Sunday, 08 July 2018, 09:49 GMT
gdm has defaulted to Wayland since 3.16.
Comment by Hartmut Seichter (seichterh) - Monday, 09 July 2018, 10:41 GMT
Same here. Similar stacktrace with libmutter being the trigger. And also a NVIDIA driver. For circumventing it right now, I only downgraded systemd I did not change anything regarding Wayland and GDM.
Comment by Bartłomiej Młynarczyk (bmlynarczyk) - Monday, 09 July 2018, 13:00 GMT
Same for me, disable wayland hepls. Thx Freddie Chopin.
Comment by Markus (Sekuraz) - Tuesday, 10 July 2018, 07:45 GMT
Same Problem, downgrading systemd fixed this issue.
For the record, I have a nvidia gpu with the proprietary drivers.
Comment by nicholas (nicholas) - Tuesday, 10 July 2018, 22:09 GMT
Also suffering with Wayland + Nvidia GPU + proprietary drivers.
I've filed an upstream bug. Please help me give details here: https://gitlab.gnome.org/GNOME/gnome-shell/issues/403
Comment by loqs (loqs) - Tuesday, 10 July 2018, 22:26 GMT
You might also want to mention is only occurs after updating systemd to 239 and GDM on the Nvidia proprietary drivers without WaylandEnable=false in /etc/gdm/custom.conf
Downgrading to systemd 238 and the issue does not occur. No one affected has bisected between 238 and 239 to find the trigger.
Comment by loqs (loqs) - Friday, 13 July 2018, 21:14 GMT
https://gitlab.gnome.org/GNOME/mutter/issues/223 upstream needs a backtrace with debug symbols
Comment by Freddie Chopin (Freddie Chopin) - Saturday, 14 July 2018, 07:44 GMT
I've installed mutter with debug symbols and posted the dump there, let's see if that's enough.
Comment by Alexandre Bique (babali) - Saturday, 14 July 2018, 09:19 GMT
Thank you man! :-)
Comment by Dmitrii Sutiagin (f3flight) - Tuesday, 17 July 2018, 17:51 GMT
FYI, ran into this issue today after updating the system. Recovered my ability to use my PC by rebooting with linux-lts kernel; did not downgrade anything. My system is laptop with intel + nvidia + proprietary driver nvidia 396.24-16. I use Xorg for my session but I guess the login screen is still Wayland.
Uncommenting #WaylandEnable=false in /etc/gdm/custom.conf also fixes the issue (without using lts kernel), thank you for that recommendation.
Comment by Christophe Réquillart (crequill) - Wednesday, 18 July 2018, 09:51 GMT
linux-lts didn’t work for me. Downgrading systemd resolve it. Thank you Barakah.
Comment by Barakah AlRashedi (unixv) - Wednesday, 18 July 2018, 12:16 GMT
Hey @Christophe, You are welcome
Comment by loqs (loqs) - Friday, 20 July 2018, 05:36 GMT Comment by Jonathan De Nil (ulukai) - Sunday, 05 August 2018, 21:35 GMT
Still experiencing this issue. Only 1/5 or so boot attempts succeed.
Had an update of Mutter 3.28.3-2 today but the problem persists.
When should we expect an updated package for this?
Comment by Renzo Duin (rubikscraft) - Sunday, 05 August 2018, 21:37 GMT
Jup, i'm also still experiencing these issues.
Comment by Christian Hesse (eworm) - Monday, 06 August 2018, 10:16 GMT
Adding heftig for the mutter stuff.
Comment by Kaz (ksauzz) - Monday, 06 August 2018, 11:14 GMT
According to the commit histories on 3.28 branch, the fix was merged after 3.28.3 release. I think the next 3.28.x release resolves this issue.
https://gitlab.gnome.org/GNOME/mutter/commits/gnome-3-28
Comment by Aaron Plattner (aaronp24) - Monday, 06 August 2018, 16:18 GMT
I don't think fixing this crash actually fixes the problem described here. mutter just fails gracefully instead of crashing, but systemd still intermittently pukes with the "Failed to create session: Start job for unit user-120.slice failed with 'canceled'" error.
Comment by loqs (loqs) - Monday, 06 August 2018, 17:31 GMT
@aaronp24 you tested this with a patched mutter build? If you downgrade systemd to 238 does the issue no longer occur?
If so can you bisect between 238 and 239 and find which commit triggers the issue?
Comment by Aaron Plattner (aaronp24) - Monday, 13 August 2018, 20:05 GMT
Yes, I just manually installed a patched mutter on top of the rest of my system. I won't have time to bisect systemd soon, sorry.
Comment by Christophe Réquillart (crequill) - Wednesday, 29 August 2018, 12:09 GMT
Always same issue with systemd 239 (gdm cannot start: 'Failed to create backend: No resources' and not able to switch tty)
See https://gitlab.gnome.org/GNOME/mutter/issues/261
Comment by Sebastian Eberhardt (un533n) - Friday, 14 September 2018, 18:55 GMT
As of today, downgrading systemd doesn't work anymore.

This means basically all systems with nvidia graphics cards cant start gdm/gnome at the moment.

Only way right now to make the system start the GUI I found so far is to use nouveau. However this is not really an option (slow, no CUDA, etc.)

Why is this only medium severity? It seems to affect a lot of systems?
Comment by Christian Hesse (eworm) - Friday, 14 September 2018, 19:23 GMT
As of today nobody bisected this. Sorry, I can not reproduce.

Everybody affected can rebuild last systemd package against current libidn (or libidn2).
Comment by Daniel Sato (pretzelface) - Friday, 14 September 2018, 19:32 GMT
Are you suggesting that we rebuild systemd 238 or 239 against libidn2?
Comment by Christian Hesse (eworm) - Friday, 14 September 2018, 19:36 GMT
Sorry, should read latest working package systemd 238.x.
Comment by loqs (loqs) - Friday, 14 September 2018, 20:07 GMT
You will need to cherry pick the statx fixes for each bisection step.
Comment by Sebastian Eberhardt (un533n) - Saturday, 15 September 2018, 06:21 GMT
Its not working any longer with systemd 238.x. When reverting to 238 or blacklisting the update to 239 errors about the missing libidn occur, although the library is present.

Interesting that you can not reproduce this ... I have several systems with nvidia graphics cards (at home and at the office) and all of them have the exact same problem. It also occurs on a fresh install with only the bare minimum of packages installed from official repos to make gnome run (and nvidia driver).
Comment by Kaz (ksauzz) - Saturday, 15 September 2018, 06:45 GMT
I downgraded libidn to 1.34-2 today since I also faced the issue. It works for me.
Comment by iodine (iodine) - Sunday, 16 September 2018, 13:01 GMT
I'm having the same issue with latest gnome-shell. systemd - 239.2, nvidia 396.54. The only way to start gnome at the moment is to switch tty and start manually.
Comment by loqs (loqs) - Sunday, 16 September 2018, 13:37 GMT
Is no one affected prepared to bisect the issue or someone has tried and needs help with the bisection?
Comment by Jeison Pandini (jeison) - Sunday, 16 September 2018, 23:37 GMT
I'm affected by this issue and available to help, just need information to how make the bisection.
Comment by Charles G (charlesg) - Monday, 17 September 2018, 00:35 GMT
Also affected by this. Since I had blaclisted libsystemd and systemd, the libidn update broke the boot again. Had to chroot to have my system working again.
Comment by loqs (loqs) - Monday, 17 September 2018, 00:43 GMT
The attached instructions should help with bisecting. As v238 does not contain systemd-resolvconf support I kept the package but it just supplies an empty directory.
It might be better to start a forum thread for the bisection.
Comment by Christian Hesse (eworm) - Friday, 21 September 2018, 21:31 GMT
Just for the record... I can not reproduce as I do not own Nvidia hardware. ;)
Comment by Jan Steffens (heftig) - Saturday, 22 September 2018, 01:21 GMT
I have Nvidia hardware and I can't reproduce.
Comment by Federico (fedev) - Sunday, 23 September 2018, 22:47 GMT
@Jan, could it be that you have:

<code>
[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false
</code>

in /etc/gdm/custom.conf ?

Because as it turns out, that is the only way I found to be able to get the graphical interface to go up. Commenting out that line brings the problem back.

Comment by Jan Steffens (heftig) - Sunday, 23 September 2018, 22:48 GMT
Nope,

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false
Comment by Federico (fedev) - Sunday, 23 September 2018, 23:26 GMT
I was going to go for the bisect however after commenting out the line I mentioned, the issue did not return. I'll keep an eye on it nonetheless.
Comment by loqs (loqs) - Sunday, 23 September 2018, 23:47 GMT
@hetfig using the nvidia driver rather than nouveau?
Comment by Jan Steffens (heftig) - Sunday, 23 September 2018, 23:47 GMT
yes.
Comment by Paste Dubrow (Nolchetyre) - Monday, 24 September 2018, 06:59 GMT
The problem has gone after disable wayland and few updates. Can not reproduce now too.
Comment by Jeison Pandini (jeison) - Monday, 24 September 2018, 14:41 GMT
After some upgrades, especially the Gnome 3.30, the problem doesn't occur anymore. I didn't need change anything.
Comment by Christoph Wurst (christophwu) - Monday, 24 September 2018, 15:05 GMT
I had two systems using the proprietary nvidia drivers that failed booting. I can, however, confirm that the issue is now seemingly fixed after a full system upgrade.
Comment by CubeTheThird (CubeTheThird) - Monday, 24 September 2018, 17:41 GMT
After a full system upgrade I still experience this issue. Regardless if I enable or disable Wayland for GDM, I am often not able to reach the DE without needing a (or several) reboot. I generally have Wayland enabled, as with this I am still able to drop to a TTY and run the reboot command. With it disabled, GDM will start, but I cannot switch TTYs nor reach the DE when the issue occurs.
Comment by Barakah AlRashedi (unixv) - Thursday, 27 September 2018, 09:22 GMT
the issue were found with systemd-239.0-2 and New update for systemd-239.2-1 has been released and after I upgraded my system the issue is disappeared. the system can boot and start GDM normally.

[2018-09-26 14:35] [ALPM] upgraded systemd (238.133-4 -> 239.2-1)

So I confirmed that issue solved. Hope will solved with other . Thank you developers for your effort.

Loading...