Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59251 - [kxmlgui] kmplot starts without toolbars (generates broken kmplotrc on start)

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Friday, 06 July 2018, 11:23 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 17 July 2018, 07:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After some update kmplot starts showing only the coordinate grid, no menu, status or toolbars. Findings:

* if I remove the file ~/.config/kmplotrc then kmplot starts properly
* if I close kmplot and start it again, it again starts with missing GUI
* explanation: kmplot generates a broken ~/.config/kmplotrc leading to the problem
* when placing a working kmplotrc (I have saved from another machine where I didn't run kmplot since the last updates), it is overwritten with a broken one when kmplot is started, on the next run it therefore starts without GUI
* diff between working and broken kmplotrc:

$ diff .config/kmplotrc_broken .config/kmplotrc_working
18,20c18
< MenuBar=Disabled
< State=AAAA/wAAAAD9AAAAAQAAAAAAAAGzAAADcvwCAAAAAfsAAAAcAEYAdQBuAGMAdABpAG8AbgBFAGQAaQB0AG8AcgAAAABBAAADcgAAAi4A////AAADRwAAA3IAAAAEAAAABAAAAAgAAAAI/AAAAAEAAAACAAAAAQAAABYAbQBhAGkAbgBUAG8AbwBsAEIAYQByAAAAAAD/////AAAAAAAAAAA=
< StatusBar=Disabled
---
> State=AAAA/wAAAAD9AAAAAQAAAAAAAAGzAAADcvwCAAAAAfsAAAAcAEYAdQBuAGMAdABpAG8AbgBFAGQAaQB0AG8AcgEAAABBAAADcgAAAisA////AAADRwAAA3IAAAAEAAAABAAAAAgAAAAI/AAAAAEAAAACAAAAAQAAABYAbQBhAGkAbgBUAG8AbwBsAEIAYQByAQAAAAD/////AAAAAAAAAAA=


Additional info:
* kmplot version is 18.04.2-1 but downgrading to one of the earlier (working) versions doesn't help, looks like some dependency causes the problem



Steps to reproduce:
update your machine to the latest state, run kmplot
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 17 July 2018, 07:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  kxmlgui 5.48.0-2
Comment by Antonio Rojas (arojas) - Friday, 06 July 2018, 11:38 GMT
Same as  FS#59233 
Comment by Michael Kogan (Photon) - Friday, 06 July 2018, 12:25 GMT Comment by Antonio Rojas (arojas) - Friday, 06 July 2018, 12:26 GMT
No, for KDE apps kxmlgui is responsible for setting up the UI, and there's a fix under review already.
Comment by Michael Kogan (Photon) - Friday, 06 July 2018, 12:30 GMT
I see, nice! Could you please post a link to the corresponding kxmlgui bug report so I can stay updated regarding the progress of the fix? Thanks!
Comment by Antonio Rojas (arojas) - Friday, 06 July 2018, 12:33 GMT Comment by Michael Kogan (Photon) - Saturday, 07 July 2018, 07:15 GMT
Thanks!

Loading...