Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59233 - [qtcreator] does not show the debug controls pane

Attached to Project: Arch Linux
Opened by Simon Schäfer (CMon) - Wednesday, 04 July 2018, 16:13 GMT
Last edited by Antonio Rojas (arojas) - Friday, 06 July 2018, 14:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
when the qt-creator is build with the current version of Qt (5.11.1) it does not show the debug controls from the second run on (see QTCREATORBUG-20724 and QTCREATORBUG-20721)

Additional info:
* package version(s)
** current latest qt packages (5.11.1)
** qt-creator v4.6.2 (prebuild from current arch)
** qt-creator v4.6.2 (self build from git repo)
** qt-creator v4.6.1 (self build from git repo)
** qt-creator v4.6.0 (self build from git repo)

Steps to reproduce (shamelessly taken from my bug report at Qt: QTCREATORBUG-20721):

* move (or remove) the settings folder from .config/QtProject to have a clean start
* Start a new project (or use one of yours) for example the "Qt Widgets Application"
* hit F5 to run debug
** the view changes to debugging and you see all the fancy debug windows
* stop debugging & close the qtCreator
* Start the QtCreator select the previously project from recent Projects
* hit F5
** the view switches to Debug (on the left) but all the fancy debug windows are gone
** And from here on I found no way on getting them *all* back, without deleting all settings on each start of the QtCreator


Some more analysis:

It seems that it has to do with the Qt Version that is used:
(/) works
(n) does not work

|| || Qt 5.10.1 || Qt 5.11.0 || Qt 5.11.1 (distributed by Qt) || Qt 5.11.1 (distributed by arch linux) ||
|| QtCreator v4.6.0(git) | (/) | TODO | TODO | (n) |
|| QtCreator v4.6.1(git) | TODO | TODO | TODO | (n) |
|| QtCreator v4.6.2(git) | (/) | (/) | (/) | (n) |
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 06 July 2018, 14:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  qtcreator 4.6.2-2
Comment by Doug Newgard (Scimmia) - Thursday, 05 July 2018, 04:57 GMT
Logs?
Comment by Simon Schäfer (CMon) - Thursday, 05 July 2018, 07:43 GMT
logs of what? its a gui part thats missing, the qtcreator does not log, at least that I know of. or do you want the complete compile output from my self compiles?
Comment by Antonio Rojas (arojas) - Thursday, 05 July 2018, 09:52 GMT
This is an upstream regression in 5.11.1, no idea how it can work for you with the upstream provided packages.

https://bugreports.qt.io/browse/QTBUG-69277
Comment by Simon Schäfer (CMon) - Thursday, 05 July 2018, 13:34 GMT
Apparently this is no regression since the ticket seems to be closed without any fix. And why its working with the upstream Qt5.11.1 no clue either, but since I could not find the configure and buildflags Qt is using for their packages, I was unable to compare those to the ones from arch.

Loading...