Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59224 - [dotnet-sdk] messes with runtime identifier

Attached to Project: Community Packages
Opened by morguldir (morguldir) - Tuesday, 03 July 2018, 15:13 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 03 July 2018, 18:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

[dotnet-core] 2.1.1+301-1 The dotnet packages are adding their own Runtime Identifiers, RID's are used to identify the operating system that it is running on so that you can target libraries to that platform, the package maintainer has decided to add their own RID which breaks this functionality for arch users.

The intended way the shell scripts should work is that they set __PortableBuild to 1 for unsupported versions, and then change the version to just linux-$arch if the variable is set to 1, however, if you look at the patch that adds arch, it adds an if statement right before it sets the portable build variable.

https://git.archlinux.org/svntogit/community.git/tree/trunk/dotnet-coreclr-rid.patch?h=packages/dotnet-core


This is a change that should be made upstream so that having arch as an RID can be translated into linux.

https://docs.microsoft.com/en-us/dotnet/core/rid-catalog

Duplicate of #59195 because bug searching is bad
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 03 July 2018, 18:44 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Don't do that

Loading...