Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59210 - [gimp] Crash

Attached to Project: Arch Linux
Opened by dhiraj (dksktm) - Monday, 02 July 2018, 09:41 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 04 July 2018, 02:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Christian Hesse (eworm)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

GNU Image Manipulation Program version 2.10.2
git-describe: GIMP_2_10_0-292-gbe7f9b433a
C compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --enable-default-pie --enable-default-ssp
Thread model: posix
gcc version 8.1.1 20180531 (GCC)

using GEGL version 0.4.3 (compiled against version 0.4.3)
using GLib version 2.56.1 (compiled against version 2.56.1)
using GdkPixbuf version 2.36.12 (compiled against version 2.36.12)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.42.1 (compiled against version 1.42.1)
using Fontconfig version 2.13.0 (compiled against version 2.13.0)
using Cairo version 1.15.12 (compiled against version 1.15.12)

> fatal error: Segmentation fault

Stack trace:
/usr/lib/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3f8)[0x7f8dd9d4f758]
gimp-2.10(+0xc2d40)[0x55f785789d40]
gimp-2.10(+0xc3198)[0x55f78578a198]
gimp-2.10(+0xc3909)[0x55f78578a909]
/usr/lib/libpthread.so.0(+0x11a80)[0x7f8dd61e3a80]
gimp-2.10(gimp_tools_restore+0x4af)[0x55f7857ed7cf]
gimp-2.10(+0xc5882)[0x55f78578c882]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x19d)[0x7f8dd6aaba4d]
/usr/lib/libgobject-2.0.so.0(+0x22e40)[0x7f8dd6abee40]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0xa86)[0x7f8dd6ac76f6]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x90)[0x7f8dd6ac8130]
gimp-2.10(gimp_restore+0x11b)[0x55f785a51c4b]
gimp-2.10(app_run+0x4c6)[0x55f785789686]
gimp-2.10(main+0x3b1)[0x55f785788df1]
/usr/lib/libc.so.6(__libc_start_main+0xeb)[0x7f8dd5e3906b]
gimp-2.10(_start+0x2a)[0x55f785788f8a]
This task depends upon

Comment by Doug Newgard (Scimmia) - Monday, 02 July 2018, 16:38 GMT
Ok, so what? What were you doing at the time? Is it reproducible? Is it a packaging problem?
Comment by dhiraj (dksktm) - Monday, 02 July 2018, 17:48 GMT
I dont know what to do. What should I do ?
Comment by loqs (loqs) - Monday, 02 July 2018, 18:47 GMT
As per https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines unless it is a packaging issue report it upstream.
Comment by Jim (MustardOnCheese) - Wednesday, 04 July 2018, 01:39 GMT
I get this same crash. I opened an JPEG image that is 1620x2160 and I was trying out different filters. Some filters I would undo via CTRL+Z. After doing this repeatedly, Gimp crashed with the information below.

GNU Image Manipulation Program version 2.10.2
git-describe: GIMP_2_10_0-292-gbe7f9b433a
C compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --enable-default-pie --enable-default-ssp
Thread model: posix
gcc version 8.1.1 20180531 (GCC)

using GEGL version 0.4.3 (compiled against version 0.4.3)
using GLib version 2.56.1 (compiled against version 2.56.1)
using GdkPixbuf version 2.36.12 (compiled against version 2.36.12)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.42.1 (compiled against version 1.42.1)
using Fontconfig version 2.13.0 (compiled against version 2.13.0)
using Cairo version 1.15.12 (compiled against version 1.15.12)

> fatal error: Segmentation fault

Stack trace:
/usr/lib/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3f8)[0x7f3a709bb758]
gimp-2.10(+0xc2d40)[0x56226f60fd40]
gimp-2.10(+0xc3198)[0x56226f610198]
gimp-2.10(+0xc3909)[0x56226f610909]
/usr/lib/libpthread.so.0(+0x11a80)[0x7f3a6ce4fa80]
/usr/lib/libgegl-0.4.so.0(gegl_buffer_cl_cache_flush+0x73)[0x7f3a6ebfa653]
/usr/lib/libgegl-0.4.so.0(gegl_sampler_get+0x9f)[0x7f3a6ebfd18f]
/usr/lib/gegl-0.4/gegl-common.so(+0x5f731)[0x7f3a4a44b731]
/usr/lib/libgegl-0.4.so.0(+0x62efd)[0x7f3a6ec18efd]
/usr/lib/libglib-2.0.so.0(+0x75463)[0x7f3a6d466463]
/usr/lib/libglib-2.0.so.0(+0x74a2a)[0x7f3a6d465a2a]
/usr/lib/libpthread.so.0(+0x7075)[0x7f3a6ce45075]
/usr/lib/libc.so.6(clone+0x3f)[0x7f3a6cb7a53f]
Comment by Vincent Gay (vgay) - Thursday, 05 July 2018, 06:02 GMT
I've exactly the same problem. Gimp is very unstable and crash regularly. Need to downgrade to 2.8

my environment : Archlinux up to date, openbox as window manager

A log I found in ~/.config/GIMP/2.10/CrashLog
/usr/lib/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3f8)[0x7fb20f891758]
gimp(+0xc2d40)[0x55ff80c33d40]
gimp(+0xc3198)[0x55ff80c34198]
gimp(+0xc3909)[0x55ff80c34909]
/usr/lib/libpthread.so.0(+0x11a80)[0x7fb20bd25a80]
/usr/lib/libc.so.6(gsignal+0x10b)[0x7fb20b98e86b]
/usr/lib/libc.so.6(abort+0x129)[0x7fb20b97940e]
/usr/lib/libc.so.6(+0x212e0)[0x7fb20b9792e0]
/usr/lib/libc.so.6(+0x2f112)[0x7fb20b987112]
/usr/lib/libX11.so.6(+0x41c3a)[0x7fb20b01bc3a]
/usr/lib/libX11.so.6(+0x41ceb)[0x7fb20b01bceb]
/usr/lib/libX11.so.6(_XEventsQueued+0x5d)[0x7fb20b01bfdd]
/usr/lib/libX11.so.6(XFlush+0x1a)[0x7fb20affe37a]
gimp(gimp_displays_set_busy+0x73)[0x55ff80d163a3]
gimp(+0xc759a)[0x55ff80c3859a]
gimp(+0x2d5e1f)[0x55ff80e46e1f]
gimp(+0x36ee8f)[0x55ff80edfe8f]
gimp(gimp_procedure_execute+0x337)[0x55ff80ed34e7]
gimp(gimp_pdb_execute_procedure_by_name_args+0x20a)[0x55ff80ecc69a]
gimp(gimp_pdb_execute_procedure_by_name+0x3db)[0x55ff80eccb6b]
gimp(+0xc2c7e)[0x55ff80c33c7e]
gimp(+0xc3198)[0x55ff80c34198]
gimp(+0xc3909)[0x55ff80c34909]
/usr/lib/libpthread.so.0(+0x11a80)[0x7fb20bd25a80]
/usr/lib/libc.so.6(gsignal+0x10b)[0x7fb20b98e86b]
/usr/lib/libc.so.6(abort+0x129)[0x7fb20b97940e]
/usr/lib/libc.so.6(+0x212e0)[0x7fb20b9792e0]
/usr/lib/libc.so.6(+0x2f112)[0x7fb20b987112]
/usr/lib/libX11.so.6(+0x41c3a)[0x7fb20b01bc3a]
/usr/lib/libX11.so.6(+0x41ceb)[0x7fb20b01bceb]
/usr/lib/libX11.so.6(_XEventsQueued+0x5d)[0x7fb20b01bfdd]
/usr/lib/libX11.so.6(XPending+0x57)[0x7fb20b00dca7]
/usr/lib/libgdk-x11-2.0.so.0(+0x56d27)[0x7fb20e908d27]
/usr/lib/libglib-2.0.so.0(g_main_context_check+0x202)[0x7fb20c312f22]
/usr/lib/libglib-2.0.so.0(+0x4c4c6)[0x7fb20c3134c6]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0xd2)[0x7fb20c3138e2]
gimp(app_run+0x36f)[0x55ff80c3352f]
gimp(main+0x3b1)[0x55ff80c32df1]
/usr/lib/libc.so.6(__libc_start_main+0xeb)[0x7fb20b97b06b]
gimp(_start+0x2a)[0x55ff80c32f8a]
Comment by Stefan Schick (pommes_) - Monday, 12 August 2019, 21:20 GMT
Does this crash still occur with the current Gimp Version (>=2.10.12) in the repositories?

Possible duplicate of: FS#59140 - [gimp] Crash when image edition

Loading...