Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59179 - [dotnet-sdk] aspnet-runtime should at least be an optional dependency

Attached to Project: Community Packages
Opened by Sergio Tridente (TioDuke) - Thursday, 28 June 2018, 22:10 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 09 July 2018, 06:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Package aspnet-runtime used to be a dependency for dotnet-sdk. It should at least be an optional dependency.

Additional info:
* package version(s) : 2.1.1+301-1


Steps to reproduce: None. It should be at least an optional dependency
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 09 July 2018, 06:00 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 29 June 2018, 07:18 GMT
Why?
Comment by Sergio Tridente (TioDuke) - Saturday, 30 June 2018, 02:31 GMT
The dotnet-sdk is used for developieng dotnet (code) applications. That's why it requires the dotnet-runtime. Now, if you want to develop aspnet dotnet applications you need the aspnet-runtime. That's why I believe it should be made an optional dependency for dotnet-sdk
Comment by Doug Newgard (Scimmia) - Wednesday, 04 July 2018, 02:47 GMT
That doesn't sound right. The deps are for running the software, not for what you want to develop.

Loading...