Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59163 - [nodejs-lts-carbon] needs rebuild due to libuv update

Attached to Project: Community Packages
Opened by Michael (Zrax) - Wednesday, 27 June 2018, 22:25 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Thursday, 19 July 2018, 13:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
The current release of nodejs-lts-carbon will sometimes fail an assertion from libuv interfaces (See example below). Rebuilding nodejs-lts-carbon locally on my system with no changes fixed the assertion.

Additional info:
* package version(s): 8.11.3-1
* config and/or log files etc.: See below
* This was also reproduced by at least two other users who commented on the 'code' aur page.


Steps to reproduce:
1) Install nodejs-lts-carbon
2) Build 'code' from AUR (for example)
3) Early in the build process (yarn's Linking dependencies step), nodejs will crash with the following output excerpt:

...
[3/4] Linking dependencies...
[---------------------------------------------------------------------] 0/18064node[11279]: ../src/node_file.cc:353:void node::{anonymous}::After(uv_fs_t*): Assertion `0 && "Unhandled eio response"' failed.
1: node::Abort() [node]
2: 0x55dfbf7a893b [node]
3: 0x55dfbf7e17f7 [node]
4: uv__work_done [/usr/lib/libuv.so.1]
5: 0x7f6bed77b7f8 [/usr/lib/libuv.so.1]
6: uv__io_poll [/usr/lib/libuv.so.1]
7: uv_run [/usr/lib/libuv.so.1]
8: node::Start(uv_loop_s*, int, char const* const*, int, char const* const*) [node]
9: node::Start(int, char**) [node]
10: __libc_start_main [/usr/lib/libc.so.6]
11: _start [node]
...
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Thursday, 19 July 2018, 13:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.11.3-3
Comment by Bruno Pagani (ArchangeGabriel) - Thursday, 28 June 2018, 10:02 GMT
I’ve rebuilt the package, please let me know if that fixed it for you.
Comment by Michael (Zrax) - Thursday, 28 June 2018, 16:30 GMT
Yep, that appears to have fixed it. Thanks!
Comment by Klemens Schölhorn (klemens) - Saturday, 14 July 2018, 22:48 GMT
This needs another rebuild because of the libuv 1.22.0 update. Building 'code' form AUR again fails with 8.11.3-2 (it just segfaults), but works with a rebuilt version of nodejs-lts-carbon.
Comment by Max Ammann (maxammann) - Wednesday, 18 July 2018, 17:01 GMT
Cool, finally found the bug report :)

Segfaults for me:

```
pacman -S nodejs-lts-carbon yarn
git clone https://github.com/yarnpkg/example-yarn-package
cd example-yarn-package
yarn
```
Comment by Max Ammann (maxammann) - Wednesday, 18 July 2018, 17:01 GMT
@Zrax how do you get the detailed output of the segfault? I had to dig though core dumps for find a reference about libuv
Comment by Bruno Pagani (ArchangeGabriel) - Wednesday, 18 July 2018, 22:11 GMT
> I’ve rebuilt the package, please let me know if that fixed it for you.
Comment by Max Ammann (maxammann) - Thursday, 19 July 2018, 11:08 GMT
Yes, that fixed it, thanks

Loading...