Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59161 - [xdg-utils] file should be added as an optional dependency

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Wednesday, 27 June 2018, 14:37 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 19 November 2019, 06:07 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
In /usr/bin/xdg-mime, `file` is used to determine the MIME type of a given path under specific scenarios (line 724). As a result, it should be added as an optional dependency.

Additional info:
extra/xdg-utils 1.1.3-2

Steps to reproduce:
1. Make sure neither core/file nor extra/perl-file-mimeinfo is installed
2. `xdg-mime query filetype "$HOME"` is broken
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 19 November 2019, 06:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  in preperation of transitional dependencies "file" let it beomce a true dependency due to "xdg-mime" heavily depending on it.
Comment by Andreas Radke (AndyRTR) - Wednesday, 27 June 2018, 14:56 GMT
File pkg is part of base group and expected to be installed on every Arch system. When you remove it you should know what you're doing.
Comment by Eli Schwartz (eschwartz) - Sunday, 14 October 2018, 05:08 GMT
Hmm, logically speaking we should remove the dependency on "sh" for the same reason. Being without /bin/sh on any form of Unix is rather insane, even if we didn't have bash as part of the base system.
Comment by Eli Schwartz (eschwartz) - Tuesday, 19 November 2019, 02:01 GMT
> "file" isn't anymore part of base group. so let's make it a true dependency follwing "which"

Reopening to point out that "file" is a direct dependency of the "base" metapackage, for the express reason that we require it to exist for scripting purposes (like, indeed, xdg-utils uses it). Of course, if you still want to include it, that is fine... but it's not strictly correct to say that it is needed due to the removal of the base group.

(Note also that the base metapackage depends on bash in order to guarantee that a POSIX /bin/sh exists.)

Loading...