Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59149 - [dwarffortress] version 0.44.11-1 seg faults with linux kernel 4.17.2-1

Attached to Project: Community Packages
Opened by Israel Ribeiro (israveri) - Tuesday, 26 June 2018, 02:20 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Tuesday, 03 July 2018, 20:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

With said kernel version, dwarffortress 0.44.10 kept working fine, upgrading it to 0.44.11-1 makes it instantly segfault.


Additional info:
The problem is located in the /opt/dwarffortress/libs/libgraphics.so file. Downloading the 0.44.11 version from the source website and copying said file over the package one fixes the problem.

Below is the backtrace I get running coredumpctl and gdb on the process:

#0 0x000000000000001c in ()
#1 0x00007fa759579c3d in musicsoundst::set_song(std::string&, std::pair<bool, int>) () at /opt/dwarffortress/libs/libgraphics.so
#2 0x0000000000ac24a2 in beginroutine() ()
#3 0x00007fa7594d92b2 in enablerst::loop(std::string) () at /opt/dwarffortress/libs/libgraphics.so
#4 0x00007fa7594cde51 in main () at /opt/dwarffortress/libs/libgraphics.so
#5 0x00007fa7587bd06b in __libc_start_main () at /usr/lib/libc.so.6
#6 0x00000000004092ef in ()

I opened an issue in the dwarf fortress bug tracker before discovering the issue was in the package itself. Link to the issue below.
http://www.bay12games.com/dwarves/mantisbt/view.php?id=10799
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Tuesday, 03 July 2018, 20:29 GMT
Reason for closing:  Fixed
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 26 June 2018, 06:40 GMT
Most likely a problem of the optimization level. I'll check it out.
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 03 July 2018, 09:01 GMT
Check now.
Comment by Israel Ribeiro (israveri) - Tuesday, 03 July 2018, 15:40 GMT
Tested with kernel 4.17.3-1 and it worked fine.

Loading...