Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59144 - [texlive-core] Wrong spacing between rubric title and first entry using curve.cls

Attached to Project: Arch Linux
Opened by Alexander Noack (xy) - Monday, 25 June 2018, 11:39 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Saturday, 08 December 2018, 01:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Highly likely an upstream bug. Using the curve class, the first entry
is positioned too high. The space between the rubric title and the
beginning of the first line (baseline+height) of rubric entries is too
small. It looks like the allocated space for the first entry is correct
though: If the first entry contains only one line, the space from the
title to the second entry seems to be correct (there is a gap between
the first two entries then). If the first entry contains two lines, the
second line is properly put below the last line of the first entry (the
gap disappears).

Since the curve.cls is not part of the texlive-core package, and this
package contains many packages, I don't know how to track the bug. It's
introduced with the given package version (see below), updating from
2017.46770-1. Also, since the bug is not introduced in the curve class,
it might occur in other classes and cases, too.

I would like to investigate further, what package is creating this bug,
but the package list and changed files seem too big. I would appreciate
help on how to track down a bug like this, so I can learn it and write
a bug report (and maybe even a fix) upstream.


Additional info:
* package version(s)
texlive-core-2018.47471-1
texlive-pictures-2018.47373-1 (contains curve.cls)


Steps to reproduce:
Save tex document as `doc.tex`. Then run
$ pdflatex doc.tex

   doc.tex (0.4 KiB)
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Saturday, 08 December 2018, 01:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  texlive-core 2018.47471
Comment by Daniel M. Capella (polyzen) - Tuesday, 26 June 2018, 00:01 GMT
You could try aur/tectonic, but I'm not sure if that would help.
Comment by Alexander Noack (xy) - Tuesday, 26 June 2018, 10:22 GMT
I don't mind downgrading for a single finalized version of a CV in latex, I would like to help find the bug and fix it. So I'm looking for a way how I can limit the possibly responsible packages that introduced the bug.
Comment by Alexander Noack (xy) - Friday, 06 July 2018, 21:39 GMT
I found the bug. And then it disappeared. It was in `array.sty` in the latex-package `tools`, contained in `texlive-core`.
Line 218 introduces a new `\gdef\do@row@strut`. Commenting it out I could get the old correct behaviour. I then wanted to see whether there is a fix already implemented in a new latex version, cloned the current version from https://github.com/latex3/latex2e and then built it.

After that I could NOT reproduce the bug anymore. I reinstalled `texlive-core` and moved the git repository to another place. Still no wrong spacing, I could not reproduce it.

Could somebody try to reproduce the bug? To see whether the bug was somehow related to my computer or is just miraculously fixed in my computer and is still out there? Use the old `texlive-core-2017.46770-1` and the new `texlive-core-2018.47471-1`. Is there a difference in the output when you compile the document I provided?
Comment by Alexander Noack (xy) - Saturday, 07 July 2018, 20:18 GMT
Switching to another user account I could reproduce the bug again. I have no idea what files (cache?) changed by building latex locally. Any ideas for this behavior?

By updating the `tools` sub-package to the latest version, the bug should be fixed.
Comment by Alexander Noack (xy) - Sunday, 15 July 2018, 10:55 GMT
The bug was fixed with git commit `5a98d41db136302c5a8ff1ca097e47d6fd66f339` in the latex2e repo. So, there are two new tagged versions with a fix out: `release-2018-04-01-PL4` and `release-2018-04-01-PL5`.
Comment by Alexander Noack (xy) - Sunday, 15 July 2018, 12:04 GMT
It was issue 42 in github, just to complete this report.
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 08 December 2018, 01:51 GMT
Thanks for your investigation

Loading...