Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#59111 - [pulseaudio] Remote clients cannot connect

Attached to Project: Arch Linux
Opened by Steve (Roken) - Friday, 22 June 2018, 20:19 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 27 February 2022, 08:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



I have several machines (1 arch, and two Debian (raspberry Pi) that connect to the pulseaudio server on my main rig. With the update to pulseaudio 12.0, none of them can connect. I tried rebuilding with --disable-tcpwrap \ removed from the PKGBUILD (thinking this may help) but no change. It was working fine until the update.

The Arch client is also updated to 12.0.

The error when trying to connect is N: [pulseaudio] main.c: User-configured server at tcp:, refusing to start/autospawn.

the IP address of the server is correct.

Additional info:
* package version(s) pulseaudio 12.0
* config and/or log files etc. None.

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 27 February 2022, 08:51 GMT
Reason for closing:  None
Additional comments about closing:  Seems original poster was able to fix issue by merging delivered via pulseaudio-12 package.
Comment by Steve (Roken) - Friday, 22 June 2018, 20:19 GMT
EDIT: I should add, the result is the same with or without the port number.
Comment by Steve (Roken) - Saturday, 23 June 2018, 07:48 GMT
Additional. In a bid to start a workaround by using jack, pulse will not allow jack to start, either.
Comment by Steve (Roken) - Monday, 25 June 2018, 04:54 GMT
Further info. After swapping out for, two of the machines will now connect, with one still failing (identical client.conf files).

Jack will still not start.