Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59092 - [virtualbox] guest GUI (KDE) freezes solid after linux update to 4.17.x

Attached to Project: Community Packages
Opened by Jeff Hodd (jghodd) - Wednesday, 20 June 2018, 21:27 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 22 June 2018, 16:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: The system desktop now freezes up after the update from linux-4.16.13 to linux-4.17.2. Initially, there is some responsiveness as you mouse-over various screen components, but any app you execute is DOA.


Additional info:
* 5.2.12-2


Steps to reproduce: Update your vbox environment to linux-4.17.2 and your desktop and apps will stop functioning.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 22 June 2018, 16:24 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#59091 
Comment by Jeff Hodd (jghodd) - Wednesday, 20 June 2018, 21:56 GMT
A better description may be that mouse input is ignored in any window. You can launch new apps. But as soon as you try to interact with the mouse with any window, you can't.
Comment by Yonggang Li (gnaggnoyil) - Thursday, 21 June 2018, 17:04 GMT
Confirms that this bug happens with Xfce4 too: by far(2018-06-22) as long as `linux` is upgraded to 4.17.2 or higher and `virtualbox-guest-modules-arch` is upgraded to 5.2.12-9 or higher the whole desktop will ignore mouse clicks simply by launching any app on startup. Restarting xfce4-panel does not solve this issue.
Comment by Jeff Hodd (jghodd) - Thursday, 21 June 2018, 19:09 GMT
I went ahead and tried out the latest versions of xorg-server and xf86-input-mouse currently in testing, and neither of these resolved the problem. After the DE starts up, the fist mouse click works to open an application.

All subsequent mouse-clicks are ignored.

Mouse-over events still seem to work but are, of course, of little use. Keyboard input does appear to work.
Comment by Jeff Hodd (jghodd) - Friday, 22 June 2018, 05:35 GMT
Tried the latest version of libinput as well - still no joy, and I'm running out of graphics packages to rule out. This is looking more and more like it's going to come down to some kind of mismatch between the 4.17.x vbox kernel drivers and the virtualbox host.

Loading...