Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59090 - [linux] r8169 stops after suspend

Attached to Project: Arch Linux
Opened by Martin Baselier (martinbaselier) - Wednesday, 20 June 2018, 19:40 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 06 June 2019, 11:32 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After Suspend network stops working and system needs to be rebooted. On previous kernel it worked fine.

Additional info:
* package version(s)
current: linux-4.17.2-1-x86_64
previous: linux-4.16.13-2-x86_64

* config and/or log files etc.
lspci -s 02:00.0 -vnn
Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
Flags: bus master, fast devsel, latency 0, IRQ 125
I/O ports at d000 [size=256]
Memory at df100000 (64-bit, non-prefetchable) [size=4K]
Memory at d2100000 (64-bit, prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
Capabilities: [d0] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
Capabilities: [170] Latency Tolerance Reporting
Kernel driver in use: r8169
Kernel modules: r8169

dmesg
[ 106.710812] ACPI BIOS Error (bug): Failure looking up [\_GPE._L69.D1F0], AE_NOT_FOUND (20180313/psargs-330)
[ 106.710820] ACPI Error: Method parse/execution failed \_GPE._L69, AE_NOT_FOUND (20180313/psparse-516)
[ 106.710827] ACPI Error: AE_NOT_FOUND, while evaluating GPE method [_L69] (20180313/evgpe-509)

[ 109.471975] DMAR: DRHD: handling fault status reg 2
[ 109.471980] DMAR: [DMA Write] Request device [02:00.0] fault addr 0 [fault reason 05] PTE Write access is not set

After the problem occurred I tried to get the network back up again in the following ways:

unloading and reloading kernel module -> no effect
ip link set enp2s0 up -> no effect
unload kernel module before suspend, reload after suspend -> this resulted in the device not showing up in "ip"
dmesg showed these errors:
r8169 0000:02:00.0: Refuses to change power state, currently in D3
iommu: Removing device 0000:02:00.0 from group 6

Steps to reproduce:
use kernel 4.17.2, my network-card, suspend and then start again

Work-around: use previous kernel version.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 06 June 2019, 11:32 GMT
Reason for closing:  Fixed
Comment by miku84 (miku84) - Tuesday, 24 July 2018, 20:17 GMT
It is the same for me, seems kernel issue. 4.14 is working well.

Here as well:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1779817
Comment by Oliver Goethel (deezy) - Tuesday, 24 July 2018, 20:58 GMT Comment by loqs (loqs) - Wednesday, 25 July 2018, 16:10 GMT Comment by loqs (loqs) - Friday, 27 July 2018, 09:30 GMT Comment by Martin Baselier (martinbaselier) - Monday, 06 August 2018, 10:45 GMT
Sorry for the late reaction. But I can confirm that on kernel 4.17.11 the problem has been resolved. All works as expected again.

Loading...