Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59064 - Linux Kernel 4.17.2-1 Network devices disappear from file manager

Attached to Project: Arch Linux
Opened by John Regin (jr5040) - Tuesday, 19 June 2018, 11:51 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 21 June 2018, 15:55 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: After kernel (to 4.17.2-1) and firmware (to 20180606.d114732-1) updates via Pamac on 18-Jun-2017 all devices in file manager (Mate / Caja - Browse Network) disappeared.

Identical behaviour on Desktop PC & Laptop.

Additional info:
* package version(s) 4.17.2-1 / 20180518.2a9b2cf-1
* config and/or log files etc. Clean install, testing repository NOT enabled, AUR enabled.


Steps to reproduce: Downgraded kernel back to 4.16.13-2 and firmware back to 20180518.2a9b2cf-1 (previous versions), reboot, all devices visible in file manager once again on Desktop PC & Laptop.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 21 June 2018, 15:55 GMT
Reason for closing:  Not a bug
Comment by John Regin (jr5040) - Tuesday, 19 June 2018, 13:18 GMT
Cut & paste error. Should read -

Additional info:
* package version(s) 4.17.2-1 / 20180606.d114732-1

(couldn't see a way to edit details)
Comment by John Regin (jr5040) - Tuesday, 19 June 2018, 14:08 GMT
Re-installed kernel 4.17.2-1, but DID NOT install linux-firmware 20180606.d114732-1. Network devices remain visible in file manager on Desktop PC & Laptop.

So issue appears to be with linux-firmware 20180606.d114732-1.

I cannot see any way to edit the category above to change from kernel to firmware, resumably a moderator needs to do this? Or should I delete and re-submit?
Comment by Jan de Groot (JGC) - Wednesday, 20 June 2018, 20:32 GMT
Please attach outputs of dmesg with old and new linux-firmware package (reboot after updating).
Comment by John Regin (jr5040) - Thursday, 21 June 2018, 09:31 GMT
dmesg output attached. Also noticed 2 warning messages when upgrading/downgrading kernel (probably irrelevant, but included for completeness in attached file), same warnings udgrade or downgrade.

Anyway it now looks to me that I am wasting peoples time with this, for which I apologise profusely.

After one day with network devices visible in "Browse network" on both PC's, reboot yesterday morning (20-Jun-2018) - NO devices visible, no changes made to PC's. Reboot this morning (21-Jun-2018) and network devices are visible again, no changes made to PC's.

I have spent hours fruitlessly searching forums etc., for similar sysmptoms, nothing found. Reset entire network several times, no effect.

So it seems to me (from what I did find on forums etc.), that this "issue" is no more than usual the usual hassle that is to be expected from smb/samba. And it was simply an unfortunate coincidence that this occured at the same time as the kernel/firmware update.

I will leave this task open to allow Jan de Groot (JGC) to view, and assuming he agrees I will then request closure.

Again, my apologies for timewasting. Sorry.

Loading...