Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59042 - [texlive-core] Update caption package

Attached to Project: Arch Linux
Opened by Andreas Muttscheller (amuttsch) - Sunday, 17 June 2018, 15:07 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Saturday, 08 December 2018, 01:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

The current caption package is not fully compatible with TexLive 2018 anymore. This bug occurs when using "subfig": https://tex.stackexchange.com/questions/426088/texlive-pretest-2018-beamer-and-subfig-collide.

Updating the caption package to the newest version fixes this issue. The workaround in the thread does not work unfortunatelly.

Additional info:
Affected version: texlive-core 2018.47471-1

Steps to reproduce:
Minimal example:

\documentclass[hyperref={pdfpagelabels=false}]{beamer}

\usepackage{subfig}
\usepackage{caption}

\begin{document}
asd
\end{document}

Compile with pdflatex.
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Saturday, 08 December 2018, 01:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  texlive-core 2018.48566
includes caption v1.8a
Comment by Jochen (Alfe) - Monday, 18 June 2018, 17:05 GMT
Works even without using the subfig package.

Loading...