Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59032 - mkinitcpio output sometimes truncated during hook execution

Attached to Project: Arch Linux
Opened by Sean Enck (enckse) - Saturday, 16 June 2018, 18:32 GMT
Last edited by Dave Reisner (falconindy) - Monday, 21 January 2019, 16:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Sometimes it appears the output from mkinitcpio rebuilds during an update/upgrade hook execution will be truncated though the actual mkinitcpio step performs fully to completion/without error (_mostly_). This happens across multiple systems of various types (laptop, headless servers, etc.). It feels like the hook output is not always getting through (I've never run mkinitcpio itself, by hand, and not had all output display - hence why it seems like a hook issue)

Additional info (latest occurrence):
mkinitcpio 24-2
linux 4.16.13-2
pacman 5.1.0-2

Steps to reproduce:
I am unable to consistently reproduce this on any system, it sometimes happens but mostly does not. I am more looking to find out if there is any additional information about this and/or how to start to get to the root cause. It's mostly concerning because
1. If it fails and I don't see it failed, that would be bad
2. If the output cuts off mid-mkinitcpio hook output and I that isn't noticed and something happens that causes the process to finish this would also be bad

I have attached an output from a pacman log where you can see all the output from mkinitcpio EXCEPT whether it succeeded/failed. I have attached an additional console output where you can see the output just stops after getting through 2 hooks.

I recognize how vague/not reproducible this is, it's frustrating to not have anything consistent to report.
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 21 January 2019, 16:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in pacman by upstream commit ac959bb9c6ce549047a954109ae825158855e386
Comment by storrgie (storrgie) - Saturday, 16 June 2018, 18:35 GMT
Concur that I see this as well, not often, but it has now caused me to be examining each time mkinicpio is invoked to see if I experience a failure state.
Comment by Dave Reisner (falconindy) - Saturday, 05 January 2019, 16:57 GMT
I suspect this is likely fixed by upstream commit ac959bb9c6ce549047a954109ae825158855e386 in pacman. Regardless, it's a pacman problem, not mkinitcpio.

Loading...